CVE-2026-64618
CriticalCVSS 9.8Exploitation Probability (EPSS)
Low risk14th percentile - higher than 14% of all known CVEs
Summary
Apache Fineract (through version 1.15.0) is vulnerable to SQL Injection in the outStandingAmountPercentageCondition parameter of the /fineract-provider/api/v1/search/advance endpoint. Insufficient input neutralization allows SQL code injection.
Risk Assessment
An attacker could execute arbitrary SQL queries, leading to unauthorized data access, modification, or disclosure. This poses a serious risk to the confidentiality and integrity of the financial system.
Recommendation
Upgrade Apache Fineract to version 1.16.1, which fixes the issue. Until then, restrict access to the /search/advance endpoint.
Other vulnerabilities in Apache Fineract
See all- CVE-2017-5663High
In Apache Fineract versions 0.4.0-incubating, 0.5.0-incubating, and 0.6.0-incubating, an authenticated user with appropriate permissions can inject malicious SQL into SELECT queries. The 'sqlSearch' parameter on several endpoints is not sanitized and is directly appended to the query.
- CVE-2025-58130Critical
Insufficiently Protected Credentials vulnerability in Apache Fineract. This issue affects Apache Fineract through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.
- CVE-2026-65874High
This issue affects Apache Fineract versions up to and including 1.15.0. The Center read endpoint (GET /api/v1/centers) and the datatable entry read endpoints (GET /api/v1/datatables/{datatable}/{apptableId} and GET /api/v1/datatables/{datatable}/{apptableId}/{datatableId}) concatenate caller-supplied ordering parameters (orderBy, sortOrder, order) directly into the SQL ORDER BY clause.
- CVE-2026-57821High
In Apache Fineract up to version 1.14.0, the Office Search API (GET /api/v1/offices) is vulnerable to SQL injection. The orderBy parameter is concatenated into a SQL query without sufficient validation, allowing an authenticated user with permission to view offices to inject arbitrary SQL. This bypasses the ColumnValidator fix for CVE-2024-32838, which does not detect bare subqueries in the ORDER BY clause.
- CVE-2026-56287High
A boolean-based SQL Injection vulnerability exists in Apache Fineract's Client Search API (GET /api/v1/clients) up to version 1.14.0. The orderBy and sortOrder parameters are concatenated into a SQL query without sufficient validation, allowing an authenticated user with client view permission to inject arbitrary SQL via a crafted orderBy value.
- CVE-2026-35152High
A SQL Injection vulnerability exists in Apache Fineract's Report Execution API (runreports endpoint) in versions up to and including 1.14.0. Report parameter values are incorporated into the generated SQL query without sufficient validation, allowing an authenticated user with permission to run reports to inject arbitrary SQL.
- CVE-2025-58137High
Authorization Bypass Through User-Controlled Key vulnerability in Apache Fineract allows bypassing authorization by manipulating a user-controlled key. The issue affects versions through 1.11.0 and is fixed in version 1.12.1.
- CVE-2025-23408Medium
Apache Fineract through version 1.10.1 contains a weak password requirements vulnerability. The issue is fixed in version 1.11.0, and users are encouraged to upgrade to the latest release, version 1.13.0.
Original NVD description (English source)
Improper Neutralization of Special Elements used in an SQL Command ("SQL Injection") vulnerability exists in Apache Fineract (through version 1.15.0). The vulnerability affects the outStandingAmountPercentageCondition parameter of the /fineract-provider/api/v1/search/advance HTTP API endpoint, allowing SQL injection due to insufficient input neutralization. Users are recommended to upgrade to version 1.16.1, which will fix the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

