CVE-2026-6448
MediumCVSS 4.9Exploitation Probability (EPSS)
Low risk28th percentile - higher than 28% of all known CVEs
Summary
The Quiz and Survey Master (QSM) plugin for WordPress up to version 11.1.2 is vulnerable to time-based blind SQL injection via the 'order' parameter. An authenticated attacker with admin privileges can append additional SQL queries and extract sensitive data from the database.
Risk Assessment
Risk of database data theft, including passwords and user data, by an attacker with administrative access.
Recommendation
Update the QSM plugin to version 11.1.3 or later. Restrict admin access to trusted users only.
Other vulnerabilities in Quiz and Survey Master
See all- CVE-2026-111408High
A deserialization of untrusted data vulnerability in the ExpressTech Quiz And Survey Master (quiz-master-next) plugin allows object injection. This issue affects Quiz And Survey Master from n/a through 11.2.7.
- CVE-2026-107862Medium
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows DOM-Based XSS.This issue affects Quiz And Survey Master: from n/a through 11.2.7.
- CVE-2026-104392High
Deserialization of untrusted data vulnerability in the Quiz And Survey Master WordPress plugin, allowing object injection.
- CVE-2026-104391Medium
Stored XSS vulnerability in the Quiz And Survey Master plugin by ExpressTech. Improper input neutralization during page generation allows persistent execution of malicious scripts.
- CVE-2026-97289High
The Quiz And Survey Master (quiz-master-next) WordPress plugin contains a DOM-Based Cross-site Scripting vulnerability due to improper neutralization of input during web page generation. The issue affects versions up to and including 11.2.6.
- CVE-2026-62140Medium
The Quiz And Survey Master plugin in versions up to and including 11.2.5 contains an unauthenticated Insecure Direct Object References (IDOR) vulnerability. This allows access to objects that a user should not be authorized to reach.
- CVE-2026-14826Low
The Quiz and Survey Master (QSM) WordPress plugin before 11.2.4 does not perform a per-object ownership check on the REST routes that return a quiz's email-notification and results-page configuration, allowing users with contributor-level access and above to read the configuration, including notification recipient addresses, of quizzes created by other users.
- CVE-2026-14825Low
The Quiz and Survey Master (QSM) WordPress plugin before 11.2.4 does not perform a per-object ownership check before saving a quiz's front-end text settings, allowing users with contributor-level access and above to modify the text settings of quizzes created by other users.
- CVE-2026-15963Medium
The Quiz and Survey Master (QSM) plugin for WordPress up to version 11.2.1 is vulnerable to generic SQL Injection via the 'randon_category' quiz option. Insufficient escaping and lack of query preparation allow authenticated attackers with custom-level access to append additional SQL queries to extract sensitive information.
- CVE-2026-11780Medium
The Quiz and Survey Master plugin for WordPress up to version 11.2.1 is vulnerable to Stored Cross-Site Scripting via the 'question_title' parameter due to insufficient input sanitization and output escaping. Authenticated attackers with contributor-level access can inject arbitrary web scripts that execute when a user accesses an injected page.
Original NVD description (English source)
The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to time-based blind SQL Injection via the 'order' parameter in all versions up to, and including, 11.1.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with admin-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. If the secret key is exposed, this can be exploited by lower-privileged users.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

