CVE Catalog

CVE-2026-58188

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.77%

54th percentile - higher than 54% of all known CVEs

Summary

Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Risk Assessment

Memory safety errors can lead to arbitrary code execution, information disclosure, or service crashes, potentially disrupting the proxy server.

Recommendation

It is recommended to upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 to remediate the vulnerability.

Other vulnerabilities in Apache Traffic Server

See all
Original NVD description (English source)

Several Apache Traffic Server experimental plugins have memory-safety and limit-bypass errors. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS