CVE Catalog

CVE-2026-58162

CriticalCVSS 10.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.36%

27th percentile - higher than 27% of all known CVEs

Summary

The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI. This issue affects Apache Traffic Server versions from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, and from 10.0.0 through 10.1.3.

Risk Assessment

An attacker can influence generated certificates, potentially leading to impersonation of other services or breach of TLS trust. This could result in traffic interception or access to protected resources.

Recommendation

Upgrade to version 9.2.15 or 10.1.4, which fix the issue. Also review the certifier plugin configuration and limit trust in unverified SNI.

Other vulnerabilities in Apache Traffic Server

See all
Original NVD description (English source)

The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS