CVE Catalog

CVE-2026-57191

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.59%

48th percentile - higher than 48% of all known CVEs

Summary

An unbounded sscanf in res_pjsip_pubsub when parsing the MWI NOTIFY Message-Account field may allow an unauthenticated attacker to send a crafted packet causing a stack buffer overflow and corrupting the transport, permanently disabling all SIP functionality until restart.

Risk Assessment

An unauthenticated attacker can remotely disable all SIP functionality in the PBX, causing telephony service unavailability.

Recommendation

Update Asterisk to 20.20.1, 21.12.3, 22.10.1, 23.4.1 or the corresponding Certified Asterisk release (20.7-cert11, 22.8-cert3).

Other vulnerabilities in Asterisk

See all
Original NVD description (English source)

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unbounded `sscanf` in `res_pjsip_pubsub` when parsing the `MWI NOTIFY` `Message-Account` field may allow an unauthenticated attacker to send a carefully crafted packet that causes a stack buffer overflow and corrupts the underlying transport, permanently disabling all SIP functionality. An Asterisk restart is required to restore full operation. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS