CVE-2026-55242
HighCVSS 8.8Exploitation Probability (EPSS)
Low risk9th percentile - higher than 9% of all known CVEs
Summary
ERPNext prior to versions 15.111.0 and 16.22.0 is vulnerable to server-side template injection (SSTI) through a configuration field. An authenticated user with a standard operational role can exploit this flaw to disclose data outside their normal permission scope.
Risk Assessment
The risk involves potential leakage of sensitive organizational data by a low-privileged user, which could lead to data integrity breaches and regulatory non-compliance.
Recommendation
Immediately upgrade ERPNext to version 15.111.0 or 16.22.0, which contain the fix for the SSTI vulnerability.
Other vulnerabilities in ERPNext
See all- CVE-2018-3885High
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Specially crafted web requests can cause SQL injections resulting in data compromise through the order_by parameter.
- CVE-2018-3884High
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Specially crafted web requests can cause SQL injections resulting in data compromise.
- CVE-2018-3883High
An SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Specially crafted web requests can lead to data compromise through SQL injection attacks.
- CVE-2018-3882High
An exploitable SQL injection vulnerability exists in the authenticated part of ERPNext v10.1.6. Specially crafted web requests can cause SQL injections resulting in data compromise.
- CVE-2026-65974Critical
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.111.0 and 16.22.0, limited authenticated users can cross a permission boundary in Frappe safe execution because frappe.render_template is exposed without forcing restrict_globals, allowing server-side template injection and remote code execution. This issue is fixed in versions 15.111.0 and 16.22.0.
- CVE-2026-72911Critical
ERPNext prior to versions 15.118.0 and 16.29.0 contains a vulnerability in unsafe template rendering in the statement of accounts process. An authenticated user with a common operational role can inject template expressions, execute arbitrary server-side code, and read data across the application.
- CVE-2026-44442Critical
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to version 16.9.1, certain endpoints failed to enforce proper authorization checks, allowing users to modify data beyond their permitted role.
- CVE-2026-38431Critical
ERPNext v15.103.1 and earlier is vulnerable to Server-Side Template Injection (SSTI). Users with permission to create or edit email templates can inject template expressions executed on the server during rendering.
- CVE-2026-31017Critical
A Server-Side Request Forgery (SSRF) vulnerability was found in the Print Format functionality of ERPNext v16.0.1 and Frappe Framework v16.1.1. Insufficient sanitization of user-supplied HTML allows embedding elements like <iframe> that are fetched server-side. An attacker can force the server to make arbitrary HTTP requests to internal services, including cloud metadata endpoints, potentially leading to sensitive information disclosure.
- CVE-2025-65267Critical
In ERPNext v15.83.2 and Frappe Framework v15.86.0, improper validation of uploaded SVG avatar images allows attackers to embed malicious JavaScript. The payload executes when an administrator clicks the image link, resulting in stored XSS. This may lead to account takeover, privilege escalation, or full compromise of the ERPNext instance.
Original NVD description (English source)
ERPNext is a free and open source Enterprise Resource Planning tool. Prior to 15.111.0 and 16.22.0, an authenticated user with a standard operational role can trigger server-side template injection through a configuration field, resulting in unauthorized disclosure of data outside the user's normal permission scope. This issue is fixed in versions 15.111.0 and 16.22.0.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

