CVE-2026-54239
HighCVSS 8.8Exploitation Probability (EPSS)
Low risk23th percentile - higher than 23% of all known CVEs
Summary
In the FaustWP WordPress plugin prior to 1.8.11, only the ciphertext in the token envelope is authenticated, and the 16-byte initialization vector is excluded from the HMAC. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can yield an Administrator access token and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. The issue is fixed in 1.8.11.
Risk Assessment
An attacker with logged-in user privileges can escalate to administrator and take full control of the WordPress site, including arbitrary code execution. This can lead to complete compromise of the site and its data.
Recommendation
Update the FaustWP plugin to version 1.8.11 or later. Until patched, restrict the ability of low-privileged users to obtain authorization codes.
Related vulnerabilities
- CVE-2026-119757Critical
BTCPay Server before 2.4.2, including 2.4.2 release candidates, contains an information disclosure vulnerability that allows unauthenticated remote attackers to retrieve .macaroon credential files for an LND node. The exposed macaroon can be used to gain full control of the LND node, including moving funds, resulting in theft of funds.
- CVE-2026-111494Critical
The MatchPoint Android app incorrectly validates TLS certificates due to a TrustManager that accepts any certificate and a permissive hostname validator. The app also allows unencrypted HTTP traffic, enabling an attacker who intercepts traffic to read and modify communications, including credentials and personal data.
- CVE-2026-111490Critical
An insecure direct object reference (IDOR) vulnerability in the MatchPoint API relies on the `actingasuser` HTTP header without verifying the requester's authorization for the specified user. Manipulation of sequential identifiers allows access to personal, banking, and financial data, private messages, and physical-access QR codes, as well as modification of third-party accounts, password changes, impersonation, and virtual balance transfers.
- CVE-2026-111489Critical
A static credential embedded in the MatchPoint mobile app has been reported to return the 'autorizado' token. The report states that this token grants unauthenticated access to API services.
- CVE-2026-85076Critical
Prior to 0.9.124, an authenticated non-admin with run_events, create_events, or edit_events privilege in Cronicle can supply undeclared keys in event params through api_create_event, api_update_event, or api_run_event. A key colliding with a security-sensitive environment variable can override the plugin execution context, potentially causing privilege escalation, arbitrary code execution, data access, or service disruption.
- CVE-2026-48705Critical
Prior to 1.6.1, MONAI's PydicomReader._get_affine() trusts non-finite values in DICOM PixelSpacing, ImagePositionPatient, and ImageOrientationPatient fields and composes them into an affine matrix without validation. An unauthenticated attacker who can upload a crafted DICOM to a default MONAILabel deployment can propagate NaN or infinity values, causing inference failures, persistent datastore poisoning, or geometrically corrupted results.
- CVE-2026-46350Critical
Prior to 0.52.0, dcmjs's DecimalString and IntegerString implementations in src/ValueRepresentation.js sanitize text with a permissive regular expression and pass the result to JavaScript's Number constructor without validating finiteness or DICOM rules. Scientific notation overflow in a DS or IS field can produce Infinity or NaN, and IntegerString accepts exponent notation and values outside the signed 32-bit IS range. Applications trusting these values can propagate invalid numbers into geometry, windowing, dose scaling, and volume reconstruction.
- CVE-2026-116790Critical
Prior to 1.11.2, FreeSWITCH's inbound ICE handling accepts every connectivity check without cryptographically validating the STUN MESSAGE-INTEGRITY attribute. A network peer can forge an ICE connectivity check without SDP credentials, nominate its own address, redirect RTP and DTLS traffic, and terminate the legitimate media path, enabling eavesdropping and media injection on unencrypted legs.
- CVE-2026-116785Critical
Prior to 1.11.2, FreeSWITCH's ws_read_frame() decodes a WebSocket frame's 64-bit extended payload length with a 32-bit byte swap and narrows the result into a signed length. A value whose surviving low word becomes negative bypasses the signed size check and is reinterpreted as an enormous unsigned count, causing client bytes to overwrite memory beyond the 64 KiB receive buffer. This can corrupt connection pointers and crash FreeSWITCH, ending all concurrent sessions.
- CVE-2026-116779Critical
Prior to 1.11.3, FreeSWITCH's sofia_presence_handle_sip_i_message() splits the To user of an inbound SIP MESSAGE on a plus sign and treats the left side as a chat protocol selector. Selecting the api chat proto reaches switch_api_execute(), allowing a peer whose MESSAGE was accepted to run FreeSWITCH API commands, including operating-system command sinks, with the daemon's privileges. Exploitation has been observed in the wild.
Original NVD description (English source)
Faust.js is a headless WordPress toolkit. Prior to 1.8.11, the FaustWP WordPress plugin authenticates only the ciphertext in its token envelope and excludes the 16-byte initialization vector from the HMAC in WPE\FaustWP\Auth\encrypt() and WPE\FaustWP\Auth\decrypt() in plugins/faustwp/includes/auth/functions.php. A logged-in non-administrator who obtains an authorization code from GET /generate can modify the unauthenticated initialization vector so that CBC decryption changes the token type and user identifier while the HMAC remains valid. This can produce an access token for an Administrator and permit full WordPress REST API access, administrator-account creation, plugin installation, and arbitrary code execution. This issue is fixed in repository version 1.8.11.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

