CVE-2026-48307
HighCVSS 8.8Exploitation Probability (EPSS)
Low risk46th percentile - higher than 46% of all known CVEs
Summary
Reflected XSS vulnerability in ColdFusion versions 2025.9, 2023.20 and earlier. An attacker can inject malicious scripts into a web page, potentially leading to arbitrary code execution in the context of the current user. User interaction (clicking a malicious link) is required.
Risk Assessment
The risk includes potential session hijacking, data theft, or unauthorized actions within the application. However, exploitation requires the victim to click a crafted link.
Recommendation
Immediately update ColdFusion to version 2025.10 or 2023.21 (or later). Also consider implementing input filters and Content Security Policy (CSP) mechanisms.
Other vulnerabilities in ColdFusion
See all- CVE-2026-75994Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. The vulnerable component is restricted to an administrative network zone by default. Exploitation of this issue does not require user interaction. Scope is changed.
- CVE-2026-106624Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106622Critical
ColdFusion is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106621Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction.
- CVE-2026-106620Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could bypass security measures and gain unauthorized write access. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106619Critical
ColdFusion is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation depends on conditions beyond the attacker's control and does not require user interaction, and the scope is changed.
- CVE-2026-106612Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105903Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105899Critical
ColdFusion is affected by an Unrestricted Upload of File with Dangerous Type vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-75746Critical
ColdFusion is affected by an SQL Injection vulnerability that could result in arbitrary code execution in the context of the current user. An attacker with high privileges could exploit this to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
Original NVD description (English source)
ColdFusion versions 2025.9, 2023.20 and earlier are affected by a reflected Cross-Site Scripting (XSS) vulnerability. An attacker could exploit this vulnerability to inject malicious scripts into a web page, potentially resulting in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious link. Scope is changed.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

