CVE Catalog

CVE-2026-47271

MediumCVSS 5.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.12%

2th percentile - higher than 2% of all known CVEs

Summary

In pam_usb before 0.9.0, out-of-memory guards in xmalloc(), xrealloc(), and xstrdup() relied on assert(data != NULL), which is compiled out when NDEBUG is defined (common in release builds). The functions then silently return NULL, and every caller dereferences the result without a NULL check, crashing the PAM module. A crash in a PAM module used by sudo or login causes a local denial-of-service condition. The vulnerability is fixed in 0.9.0.

Risk Assessment

An attacker able to induce memory pressure at authentication time can lock all users out of sudo and login, causing a local denial of service.

Recommendation

Update pam_usb to version 0.9.0 or later.

Other vulnerabilities in pam_usb

See all
Original NVD description (English source)

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.0, src/mem.c implemented out-of-memory guards for xmalloc(), xrealloc(), and xstrdup() using assert(data != NULL). The C standard specifies that all assert() expressions are compiled out when NDEBUG is defined at build time. NDEBUG is commonly defined in release and packaging builds (Debian, Fedora, Arch package flags all define it via -DNDEBUG in CFLAGS). With the guard removed, xmalloc/xrealloc/xstrdup silently return NULL on allocation failure. Every caller in the codebase dereferences the return value without a NULL check -- this is the intended design, as the guard was supposed to abort before the dereference. With the guard gone, any allocation failure causes a NULL pointer dereference, crashing the PAM module. A crash in a PAM module loaded by sudo or login causes authentication to fail for the duration of the crash, creating a local denial-of-service condition. An attacker who can induce memory pressure at authentication time can lock all users out of sudo and login. This vulnerability is fixed in 0.9.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS