CVE Catalog

CVE-2026-45205

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.47%

40th percentile - higher than 40% of all known CVEs

Summary

Apache Commons Configuration from 2.2 before 2.15.0 contains an uncontrolled recursion vulnerability. Processing an untrusted YAML configuration file with cycles causes a StackOverflowError. The issue is fixed in version 2.15.0.

Risk Assessment

An attacker could supply a malicious YAML file, causing stack exhaustion and application crash, leading to denial of service. The risk affects applications processing untrusted YAML configurations.

Recommendation

Upgrade Apache Commons Configuration to version 2.15.0 or later. Until upgraded, avoid processing untrusted YAML files.

Related vulnerabilities

Original NVD description (English source)

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS