CVE-2026-44706
HighCVSS 8.5Exploitation Probability (EPSS)
Low risk13th percentile - higher than 13% of all known CVEs
Summary
SQL injection vulnerability in Chatwoot versions 2.2.0 through 4.11.2 in conversation and contact filter APIs. An authenticated attacker can inject arbitrary SQL via date or number filter parameters.
Risk Assessment
Risk includes unauthorized data access, modification, and potential database takeover.
Recommendation
Immediately upgrade Chatwoot to version 4.11.2 or later.
Other vulnerabilities in Chatwoot
See all- CVE-2026-113355Medium
Chatwoot before 4.14.0 contains a stored cross-site scripting vulnerability that allows account administrators to inject JavaScript by crafting video-embed links in Help Center articles. Attackers can use angle-bracket link destinations with double quotes to break out of the unescaped iframe src attribute in render_embed_from_match, executing scripts for public visitors and stealing cw_conversation widget tokens.
- CVE-2026-92527Medium
A vulnerability has been found in chatwoot up to 4.17.1. This impacts an unknown function of the file callbacks_controller.rb of the component Shopify OAuth. The manipulation leads to server-side request forgery. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used.
- CVE-2026-115725Medium
Chatwoot before 4.17.0 contains an authorization bypass vulnerability that allows authenticated agent bots to access other accounts by supplying a foreign contact inbox source_id. Attackers can call the conversations create endpoint with another account's source_id to create or retrieve conversations and post messages to that account's contacts.
- CVE-2026-72719Medium
Chatwoot prior to version 4.9.0 allowed authenticated account administrators to transfer Portals, Automation Rules, Macros, and Twilio Channels to other accounts through the writable account_id parameter. This could break tenant isolation and cause cross-account data exposure, unauthorized configuration changes, or loss of access to transferred resources.
- CVE-2026-63765High
Chatwoot before version 4.16.0 contains an authentication bypass vulnerability in the direct uploads controller that allows unauthenticated attackers to create arbitrary ActiveStorage blobs in any tenant account. Attackers can exploit missing authentication checks to resolve any account and conversation, then obtain signed PUT URLs to write arbitrary data to the application's storage backend.
- CVE-2026-44707Medium
Chatwoot is a customer engagement suite. From 2.14.0 to before 4.13.0, a Pre-Account Takeover (Pre-ATO) vulnerability existed in Chatwoot's authentication flow. Because email confirmation was not enforced before an account became usable, an attacker could pre-register an email address they did not own and set a password. If the legitimate owner of that email later signed in to Chatwoot using Google OAuth (or another OmniAuth provider), the OAuth flow silently confirmed the existing account without invalidating the attacker's pre-set credentials. The attacker could then continue to log in with the password they had originally chosen and access any data the victim subsequently entered into the dashboard, including PII, API keys, and other sensitive information. This vulnerability is fixed in 4.13.0.
- CVE-2026-5205Medium
In chatwoot up to version 4.11.2, the Webhooks::Trigger function in lib/webhooks/trigger.rb does not validate the url argument, leading to server-side request forgery (SSRF). The attack is remotely exploitable and the exploit is publicly available.
- CVE-2025-12246Medium
A cross-site scripting (XSS) vulnerability was found in Chatwoot up to 4.7.0 in the Admin Interface component, specifically in app/javascript/shared/components/IframeLoader.vue. Manipulating the Link argument allows script execution, and the attack can be performed remotely.
- CVE-2025-12245Medium
A vulnerability was identified in Chatwoot up to version 4.7.0 affecting the initPostMessageCommunication function in app/javascript/sdk/IFrameHelper.js of the Widget component. Manipulation of the baseUrl argument leads to an origin validation error. The vendor was contacted but did not respond.
Original NVD description (English source)
Chatwoot is a customer engagement suite. From 2.2.0 to before 4.11.2, a SQL injection vulnerability exists in the conversation and contact filter APIs. When filtering by a custom attribute of type date or number using the is_greater_than or is_less_than operators, user-supplied values in the values field of the filter payload are interpolated directly into the SQL query without parameterization. Any authenticated user with access to an account can exploit this to execute arbitrary SQL via time-based blind injection. This affects /api/v1/accounts/{account_id}/conversations/filter, /api/v1/accounts/{account_id}/contacts/filter, and /api/v1/accounts/{account_id}/custom_attribute_definitions. This vulnerability is fixed in 4.11.2.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

