CVE Catalog

CVE-2026-44582

LowCVSS 3.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.22%

12th percentile - higher than 12% of all known CVEs

Summary

In Next.js from 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments relying on shared caches with insufficient response partitioning. Collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL.

Risk Assessment

An attacker could poison a shared cache and serve users incorrect or potentially malicious content under a legitimate URL, leading to data exposure or phishing.

Recommendation

Upgrade Next.js to version 15.5.16 or 16.2.5. Review shared cache configuration to ensure proper response partitioning.

Other vulnerabilities in Next.js

See all
Original NVD description (English source)

Next.js is a React framework for building full-stack web applications. From 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. This vulnerability is fixed in 15.5.16 and 16.2.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS