CVE Catalog

CVE-2026-44312

MediumCVSS 5.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.15%

4th percentile - higher than 4% of all known CVEs

Summary

css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation.

Risk Assessment

A MITM attacker can modify loaded CSS stylesheets, potentially injecting malicious content or leaking data. The risk affects Ruby applications using css_parser to fetch remote stylesheets over HTTPS.

Recommendation

Update the css_parser gem to version 2.1.0 or 1.22.0 (or later). Until patched, avoid loading stylesheets over HTTPS from untrusted sources.

Other vulnerabilities in css_parser

See all
Original NVD description (English source)

css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS