CVE Catalog

CVE-2026-42842

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

8th percentile - higher than 8% of all known CVEs

Summary

The form plugin for Grav prior to 9.1.0 has a Stored XSS vulnerability in the select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, allowing an editor to inject JavaScript that runs in an administrator's session.

Risk Assessment

An editor-level attacker could hijack an administrator's session and act on their behalf. Fixed in 9.1.0.

Recommendation

Update the Grav form plugin to version 9.1.0 or later.

Other vulnerabilities in Grav Form Plugin

See all
Original NVD description (English source)

The form plugin for Grav adds the ability to create and use forms. Prior to 9.1.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Grav CMS Form plugin's select field template. Taxonomy tag and category values are rendered with the Twig |raw filter in the admin panel, bypassing the global autoescape protection. An editor-level user can inject arbitrary JavaScript that executes in any administrator's browser session when they view or edit any page in the admin panel. This vulnerability is fixed in 9.1.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS