CVE Catalog

CVE-2026-42225

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.16%

5th percentile - higher than 5% of all known CVEs

Summary

PJSIP prior to version 2.17, on GnuTLS builds, can accept SIP TLS transport (sip_transport_tls) connections with invalid or untrusted certificates even when the application explicitly enables certificate verification via verify_server = PJ_TRUE or verify_client = PJ_TRUE.

Risk Assessment

TLS connections may be established with untrusted parties despite enabled certificate verification, enabling man-in-the-middle attacks. This may lead to interception or impersonation of SIP communication.

Recommendation

Update PJSIP to version 2.17 or later, which patches this vulnerability.

Other vulnerabilities in PJSIP

See all
Original NVD description (English source)

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, on GnuTLS builds, the SIP TLS transport (sip_transport_tls) can accept connections with invalid or untrusted certificates even when the application explicitly enables certificate verification via verify_server = PJ_TRUE or verify_client = PJ_TRUE. This issue has been patched in version 2.17.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS