CVE-2026-41566
CriticalCVSS 9.4Exploitation Probability (EPSS)
Low risk30th percentile - higher than 30% of all known CVEs
Summary
CVE-2026-41566 involves improper handling of insufficient permissions in Apache Kvrocks version 2.8.0. This issue has been fixed in version 2.16.0.
Risk Assessment
Improper permission handling may lead to unauthorized access to system resources, posing a risk to the organization's data security.
Recommendation
It is recommended to upgrade to version 2.16.0 to mitigate this vulnerability.
Other vulnerabilities in Apache Kvrocks
See all- CVE-2026-46752Critical
Vulnerability in the cjson library in Apache Kvrocks causing Lua HEAP overflow. Affects versions from 2.0.4 to 2.15.0.
- CVE-2026-54226Medium
A vulnerability in Apache Kvrocks affects versions from 2.6.0 through 2.15.0, and users are recommended to upgrade to version 2.16.0 to fix the issue.
- CVE-2026-46751Medium
A vulnerability in Apache Kvrocks affects versions from 2.2.0 through 2.15.0, and users are recommended to upgrade to version 2.16.0 to fix the issue.
- CVE-2026-45188Low
A Relative Path Traversal vulnerability in Apache Kvrocks may allow attackers to access unauthorized system resources. The issue affects versions from 1.0.0 through 2.15.0.
- CVE-2025-59792Medium
A vulnerability in Apache Kvrocks reveals plaintext credentials in the MONITOR command. This issue affects Apache Kvrocks from 1.0.0 through 2.13.0.
- CVE-2025-59790Medium
Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.
Original NVD description (English source)
Improper Handling of Insufficient Permissions or Privileges vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: 2.8.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

