CVE Catalog

CVE-2026-41242

CriticalCVSS 9.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.77%

56th percentile - higher than 56% of all known CVEs

Summary

protobufjs versions prior to 8.0.1, 7.5.5, and 6.11.6 allow attackers to inject arbitrary code into the "type" fields of protobuf definitions. The injected code executes during object decoding using that definition.

Risk Assessment

If an application processes untrusted protobuf definitions, an attacker can execute arbitrary code in the Node.js process context, leading to application or server compromise.

Recommendation

Upgrade protobufjs to version 8.0.1, 7.5.5, or 6.11.6 (or later) and avoid compiling untrusted protobuf definitions.

Other vulnerabilities in protobufjs

See all
Original NVD description (English source)

protobufjs compiles protobuf definitions into JavaScript (JS) functions. In versions prior to 8.0.1, 7.5.5, and 6.11.6, attackers can inject arbitrary code in the "type" fields of protobuf definitions, which will then execute during object decoding using that definition. Versions 8.0.1, 7.5.5, and 6.11.6 patch the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS