CVE-2026-40793
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk22th percentile - higher than 22% of all known CVEs
Summary
Versions of Groundhogg below 4.4.1 have a broken access control issue for subscribers, potentially allowing unauthorized access to data.
Risk Assessment
Organizations may be exposed to data leaks of subscribers and other unauthorized actions, which could impact their reputation and regulatory compliance.
Recommendation
It is recommended to update Groundhogg to version 4.4.1 or later to mitigate this vulnerability.
Other vulnerabilities in Groundhogg
See all- CVE-2026-109221High
The Groundhogg plugin for WordPress (versions up to and including 4.9.3) is vulnerable to arbitrary file deletion due to insufficient file path validation in the copy_file function. An authenticated attacker with Sales Representative-level access or above can delete arbitrary files on the server, which can easily lead to remote code execution.
- CVE-2026-18548High
The Groundhogg — CRM, Newsletters, and Marketing Automation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ref' parameter in all versions up to, and including, 4.5.14 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- CVE-2026-92975High
The Groundhogg plugin for WordPress is vulnerable to Privilege Escalation in versions up to and including 4.8.3. The create_support_user() function identifies the support account solely by matching against publicly hardcoded constants, allowing an attacker with an account having login 'groundhogg' and matching email to be promoted to administrator, and to super admin on multisite.
- CVE-2026-104725High
The Groundhogg plugin for WordPress up to version 4.9 is vulnerable to privilege escalation. Missing ownership and capability checks in the 'process_edit()' function allow authenticated users with 'edit_contacts' capability (e.g., sales reps) to reassign a contact to any WordPress account, including an administrator, and then use the auto-login URL to authenticate as that administrator.
- CVE-2026-104385High
Groundhogg plugin in versions up to and including 4.8.3 contains a Sensitive Data Exposure vulnerability exploitable by an unauthenticated attacker.
- CVE-2026-104408High
The Groundhogg plugin for WordPress (versions up to 4.8.3) contains a Blind SQL Injection vulnerability due to improper neutralization of special elements in SQL commands.
- CVE-2026-97644High
The Groundhogg — CRM, Newsletters, and Marketing Automation plugin for WordPress is vulnerable to privilege escalation via contact identity rebinding. The create_contact function in the v3 REST endpoint is gated only by the add_contacts capability and forwards the full payload, including user_id, to the upsert path, bypassing ownership guards. This allows attackers with Sales Representative-level access and above to rebind a contact to an Administrator's user ID and then use the v4 email-test endpoint to gain an admin session.
- CVE-2026-85310Medium
import_contacts Path Traversal in Groundhogg <= 4.7.1 versions.
- CVE-2026-81741Medium
The Groundhogg — CRM, Newsletters, and Marketing Automation WordPress plugin before version 4.7.2 does not restrict the redirect target of its email preference confirmation flow to the site's own host, allowing unauthenticated attackers to redirect visitors to an arbitrary external URL by way of a crafted link.
- CVE-2026-81660High
The Groundhogg — CRM, Newsletters, and Marketing Automation WordPress plugin before 4.5.13 does not validate or escape values submitted to some optional web form fields before storing and outputting them in an administrative area, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks against high privilege users.
Original NVD description (English source)
Subscriber Broken Access Control in Groundhogg < 4.4.1 versions.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

