CVE Catalog

CVE-2026-40087

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.26%

18th percentile - higher than 18% of all known CVEs

Summary

LangChain prior to 0.3.84 and 1.2.28 has incomplete f-string prompt-template validation. Some template classes (DictPromptTemplate, ImagePromptTemplate) formatted templates without enforcing attribute-access validation, and validation based on top-level field names did not reject nested replacement fields inside format specifiers, potentially evaluating expressions during formatting.

Risk Assessment

This could allow execution of unauthorized Python expressions in the application context, potentially leading to data leakage or further attacks. Risk applies to applications using vulnerable LangChain template classes.

Recommendation

Update LangChain to version 0.3.84 or 1.2.28 (or later). Review applications for use of DictPromptTemplate and ImagePromptTemplate with untrusted templates.

Other vulnerabilities in LangChain

See all
Original NVD description (English source)

LangChain is a framework for building agents and LLM-powered applications. Prior to 0.3.84 and 1.2.28, LangChain's f-string prompt-template validation was incomplete in two respects. First, some prompt template classes accepted f-string templates and formatted them without enforcing the same attribute-access validation as PromptTemplate. In particular, DictPromptTemplate and ImagePromptTemplate could accept templates containing attribute access or indexing expressions and subsequently evaluate those expressions during formatting. Second, f-string validation based on parsed top-level field names did not reject nested replacement fields inside format specifiers. In this pattern, the nested replacement field appears in the format specifier rather than in the top-level field name. As a result, earlier validation based on parsed field names did not reject the template even though Python formatting would still attempt to resolve the nested expression at runtime. This vulnerability is fixed in 0.3.84 and 1.2.28.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS