CVE-2026-39919
CriticalCVSS 9.8Exploitation Probability (EPSS)
Low risk43th percentile - higher than 43% of all known CVEs
Summary
Ghostscript before 10.08.0 contains a heap-based buffer overflow in the JPEG 2000 output adapter (base/sjpx_openjpeg.c). An attacker can cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. The issue is fixed in version 10.08.0.
Risk Assessment
Memory corruption and code execution are possible by processing a malicious PDF, potentially leading to compromise of the document-processing process. The risk is high in systems that automatically process user-supplied PDFs.
Recommendation
Upgrade Ghostscript to version 10.08.0 or later. Until then, avoid processing untrusted PDFs in high-privilege contexts.
Other vulnerabilities in Ghostscript
See all- CVE-2016-7976High
The PS Interpreter in Ghostscript versions 9.18 and 9.20 allows remote attackers to execute arbitrary code via crafted userparams.
- CVE-2016-8602High
The .sethalftone5 function in Ghostscript before version 9.21 allows remote attackers to cause application crashes or potentially execute arbitrary code via a crafted Postscript document that calls .sethalftone5 with an empty operand stack.
- CVE-2016-10317High
The fill_threshhold_buffer function in base/gxht_thresh.c in Ghostscript 9.20 by Artifex Software, Inc. allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document.
- CVE-2017-6196High
Multiple use-after-free vulnerabilities in the gx_image_enum_begin function in base/gxipixel.c in Ghostscript before ecceafe3abba2714ef9b432035fe0739d9b1a283 allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PostScript document.
- CVE-2016-7979Critical
Ghostscript before 9.21 might allow remote attackers to bypass the SAFER mode protection mechanism and consequently execute arbitrary code by leveraging type confusion in .initialize_dsc_parser.
- CVE-2016-7978Critical
A use-after-free vulnerability in Ghostscript 9.20 may allow remote attackers to execute arbitrary code via reference leaks in the .setdevice function.
- CVE-2026-112922Low
Ghostscript has improper bounds validation when processing indexed color values in mesh shading data. A remote attacker can entice a user to process a crafted PDF or PostScript document, triggering an out-of-bounds memory read.
- CVE-2026-110133Medium
A flaw was found in Ghostscript. When processing a specially crafted TrueType font or a document embedding one, an accounting error during font rendering can bypass buffer size checks, triggering a heap-based buffer overflow.
- CVE-2026-112177High
A flaw was found in Ghostscript as shipped with Red Hat Enterprise Linux 8. The correction for CVE-2019-14869 was omitted during the rebase from version 9.25 to 9.27, leaving privileged .forceput operations in the .charkeys procedure insufficiently protected. Processing a specially crafted PostScript file may allow an attacker to bypass -dSAFER restrictions and access files outside the permitted paths or execute commands with the permissions of the Ghostscript process.
- CVE-2026-101258High
A flaw in Ghostscript allows bypassing the -dSAFER sandbox and executing arbitrary shell commands in the context of the Ghostscript process when rendering a crafted PostScript or EPS document. The issue chains memory corruption in document parsing with disabling of internal path access controls at runtime.
Original NVD description (English source)
Ghostscript before 10.08.0 contains a heap-based buffer overflow vulnerability in the JPEG 2000 output adapter (base/sjpx_openjpeg.c) that allows attackers to cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. When image components declare different subsampling values, the non-samescale sub-byte-depth output path allocates a row buffer sized for packed output but writes a full byte per output column regardless of bit depth, overflowing the allocation and corrupting internal chunk-allocator metadata to achieve code execution.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

