CVE-2026-39902
HighCVSS 7.2Exploitation Probability (EPSS)
Low risk34th percentile - higher than 34% of all known CVEs
Summary
In Cacti prior to version 1.2.31, the prior blocklist ([;&| `$\n\r]) omitted single-quote, double-quote, redirect operators, subshell parens and braces. An authenticated admin could save an input_string containing these characters and bypass the check.
Risk Assessment
An admin or an attacker with administrative privileges could bypass validation and introduce dangerous characters, potentially leading to command injection. This may result in code execution or further system compromise.
Recommendation
Upgrade Cacti to version 1.2.31, which contains the fix. Also review existing configurations for suspicious input_string values.
Other vulnerabilities in Cacti
See all- CVE-2016-10700High
In auth_login.php in Cacti before 1.0.0, remote authenticated users can bypass intended access restrictions by logging in as a user not in the Cacti database, because the guest user is not considered.
- CVE-2014-4000High
Cacti before 1.0.0 allows remote authenticated users to conduct PHP object injection attacks and execute arbitrary PHP code via a crafted serialized object.
- CVE-2017-16660High
Cacti version 1.1.27 allows remote authenticated administrators to conduct Remote Code Execution attacks by placing the Log Path under the web root and then making a remote_agent.php request containing PHP code in a Client-ip header.
- CVE-2017-16641High
In Cacti 1.1.27, the lib/rrd.php file allows remote authenticated administrators to execute arbitrary OS commands via the path_rrdtool parameter in an action=save request to settings.php.
- CVE-2017-1000031High
CVE-2017-1000031 is an SQL injection vulnerability in graph_templates_inputs.php in Cacti 0.8.8b that allows remote attackers to execute arbitrary SQL commands via the graph_template_input_id and graph_template_id parameters.
- CVE-2016-2313High
The auth_login.php file in Cacti before version 0.8.8g allows remote authenticated users who use web authentication to bypass intended access restrictions by logging in as a user not in the Cacti database.
- CVE-2016-3659High
SQL injection vulnerability in graph_view.php in Cacti 0.8.8.g allows remote authenticated users to execute arbitrary SQL commands via the host_group_data parameter.
- CVE-2015-4454High
SQL injection vulnerability in the get_hash_graph_template function in lib/functions.php in Cacti before version 0.8.8d allows remote attackers to execute arbitrary SQL commands via the graph_template_id parameter to graph_templates.php.
- CVE-2015-4342High
SQL injection vulnerability in Cacti before version 0.8.8d allows remote attackers to execute arbitrary SQL commands via unspecified vectors involving a cdef id.
- CVE-2014-2709High
The lib/rrd.php file in Cacti versions 0.8.7g, 0.8.8b, and earlier contains a vulnerability that allows remote attackers to execute arbitrary commands via shell metacharacters in unspecified parameters.
Original NVD description (English source)
Cacti is an open source performance and fault management framework. Prior to version 1.2.31, the prior blocklist ([;&| `$\\n\r]) omitted single-quote, double-quote, redirect operators, subshell parens and braces. An authenticated admin could save an input_string` containing single-quote, redirect operator, or subshell parens, and pass the check. This issue has been patched in version 1.2.31.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

