CVE-2026-39379
HighCVSS 7.1Exploitation Probability (EPSS)
Low risk30th percentile - higher than 30% of all known CVEs
Summary
In GeoNetwork from 3.0.0 until 4.2.15 and 4.4.10, requesting a nonexistent or unauthorized service URL can cause an error page to reflect attacker-controlled request content inside an AngularJS application without adequately neutralizing it for template evaluation. A remote attacker can induce a victim, including an administrator, to open a crafted link so the reflected value is evaluated as an AngularJS template expression, which combined with known AngularJS sandbox-escape techniques can execute arbitrary JavaScript in the victim's authenticated browser session.
Risk Assessment
Potential execution of arbitrary JavaScript in the victim's authenticated session, information disclosure, or actions performed as the victim, including an administrator. Requires user interaction with a crafted link.
Recommendation
Update GeoNetwork to version 4.2.15 or 4.4.10 or later and inform users about the risk of opening unknown links to GeoNetwork instances.
Other vulnerabilities in GeoNetwork
See all- CVE-2026-58400Critical
GeoNetwork is a catalog application to manage spatially referenced resources. Prior to versions 4.4.12 and 4.2.17, the Saxon XSLT processor used to render formatters is configured without secure processing (FEATURE_SECURE_PROCESSING) and without disabling Java extension functions (ALLOW_EXTERNAL_FUNCTIONS). Any stylesheet loaded by GeoNetwork can therefore invoke java.lang.Runtime.exec() or java.lang.ProcessBuilder directly, achieving arbitrary command execution as the GeoNetwork process user. A user with sufficient privileges to upload a formatter can deliver a .xsl file containing Java extension call that execute arbitrary OS commands with the privileges of the GeoNetwork process. The issue is patched in GeoNetwork versions 4.4.12 and 4.2.17.
- CVE-2026-46487High
In GeoNetwork from 4.0.0-alpha.1 until 4.2.16 and 4.4.11, the Elasticsearch-backed search proxy can skip GeoNetwork's access-control filter injection when a client request has an omitted query field. The request is then forwarded to Elasticsearch without group visibility, draft exclusion, record ownership, or portal-specific filtering, allowing an unauthenticated remote attacker to retrieve the full indexed contents of metadata records that should not be publicly visible.
- CVE-2026-55864High
In GeoNetwork prior to 4.2.17 and 4.4.12, the POST /api/tools/ogc/sld endpoint accepted a caller-supplied WMS server URL and performed a server-side HTTP GET without destination validation. An anonymous attacker could make the GeoNetwork server send requests to internal hosts not publicly reachable. When the response was XML, the endpoint could store and return the fetched body.
- CVE-2026-63219High
GeoNetwork is a catalog application to manage spatially referenced resources. Prior to versions 4.4.12 and 4.2.17, the API endpoint for creating a new formatter via file upload is unprotected and allows the upload of external uncontrolled files. An unauthenticated attacker can upload arbitrary .xsl or .zip formatter files to the server.
- CVE-2026-53573Medium
In GeoNetwork versions 3.12.0 to 4.2.16 and 4.4.11, unsafe redirect validation in GeonetworkOAuth2LoginAuthenticationFilter and KeycloakAuthenticationProcessingFilter permits an attacker-controlled external redirect after login.
Original NVD description (English source)
GeoNetwork is a catalog application to manage spatially referenced resources. From 3.0.0 until 4.2.15 and 4.4.10, requesting a nonexistent or unauthorized service URL can cause an error page to reflect attacker-controlled request content inside an AngularJS application without adequately neutralizing it for template evaluation. A remote attacker can induce a victim, including an administrator, to open a crafted link so the reflected value is evaluated as an AngularJS template expression. Combined with known AngularJS sandbox-escape techniques, this can execute arbitrary JavaScript in the victim's authenticated browser session, disclose information, or perform actions as the victim. This issue is fixed in versions 4.2.15 and 4.4.10.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

