CVE Catalog

CVE-2026-35577

MediumCVSS 6.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

8th percentile - higher than 8% of all known CVEs

Summary

Apollo MCP Server prior to 1.7.0 did not validate the Host header on incoming HTTP requests when using StreamableHTTP transport. In configurations running on localhost without additional authentication or network controls, a malicious website visited by a local user could use DNS rebinding to bypass same-origin policy and issue requests to the local MCP server.

Risk Assessment

An attacker could invoke tools or access resources exposed by the MCP server on behalf of the local user. The risk is limited to HTTP transport and reduced by authentication or network access controls.

Recommendation

Update Apollo MCP Server to version 1.7.0 or later. In the meantime, enable authentication and network controls, and avoid exposing the server on localhost without protections.

Related vulnerabilities

Original NVD description (English source)

Apollo MCP Server is a Model Context Protocol server that exposes GraphQL operations as MCP tools. Prior to version 1.7.0, the Apollo MCP Server did not validate the Host header on incoming HTTP requests when using StreamableHTTP transport. In configurations where an HTTP-based MCP server is run on localhost without additional authentication or network-level controls, this could potentially allow a malicious website—visited by a user running the server locally—to use DNS rebinding techniques to bypass same-origin policy restrictions and issue requests to the local MCP server. If successfully exploited, this could allow an attacker to invoke tools or access resources exposed by the MCP server on behalf of the local user. This issue is limited to HTTP-based transport modes (StreamableHTTP). It does not affect servers using stdio transport. The practical risk is further reduced in deployments that use authentication, network-level access controls, or are not bound to localhost. This vulnerability is fixed in 1.7.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS