CVE Catalog

CVE-2026-3495

LowCVSS 3.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.14%

3th percentile - higher than 3% of all known CVEs

Summary

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to escape some variables that could contain malicious content during error page composition, which allows an attacker with access to edit some site configuration to execute malicious code via injecting JS as part of those values.

Risk Assessment

An attacker with site configuration edit permissions could inject malicious JavaScript, potentially leading to code execution in other users' browsers and session hijacking.

Recommendation

Update Mattermost to a version later than 11.5.1 or 10.11.13 to fix the vulnerability.

Other vulnerabilities in Mattermost

See all
Original NVD description (English source)

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to escape some variables that could contain malicious content during error page composition which allows an attacker with access to edit some site configuration to execute some malicious code via injecting some JS as part of those values.. Mattermost Advisory ID: MMSA-2026-00622

Vulnerability data from NVD (NIST) · CISA KEV · EPSS