CVE Catalog

CVE-2026-33227

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.42%

36th percentile - higher than 36% of all known CVEs

Summary

Apache ActiveMQ Client, Broker, All, and Web contain an improper validation and restriction of a classpath path name vulnerability. An authenticated user-provided 'key' value could be constructed to traverse the classpath due to path concatenation, exposing the application to a classpath resource loading vulnerability that could be chained with other attacks.

Risk Assessment

An authenticated attacker could exploit the classpath traversal to load unauthorized resources, potentially leading to further exploitation when chained with other vulnerabilities.

Recommendation

Upgrade Apache ActiveMQ to version 5.19.4 or 6.2.3 (or later). Ensure the fix is applied, especially on Windows environments.

Other vulnerabilities in Apache ActiveMQ

See all
Original NVD description (English source)

Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS