CVE Catalog

CVE-2026-32990

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.31%

23th percentile - higher than 23% of all known CVEs

Summary

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. Affects Apache Tomcat versions 11.0.15 through 11.0.19, 10.1.50 through 10.1.52, and 9.0.113 through 9.0.115.

Risk Assessment

Improper input validation may lead to various attacks depending on context, potentially including security bypass or unexpected server behavior. Organizations using the listed versions are exposed.

Recommendation

Upgrade Apache Tomcat to version 11.0.20, 10.1.53, or 9.0.116, which fix the issue.

Other vulnerabilities in Apache Tomcat

See all
Original NVD description (English source)

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS