CVE Catalog

CVE-2026-32892

CriticalCVSS 9.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
1.53%

75th percentile - higher than 75% of all known CVEs

Summary

Chamilo LMS contains an OS Command Injection vulnerability in the file move function where user-controlled path values are passed directly into exec() shell commands without escapeshellarg(). Any authenticated user who is a teacher in a course can move a document and trigger arbitrary command execution as the web server user. The issue is fixed in versions 1.11.38 and 2.0.0-RC.3.

Risk Assessment

An authenticated user can execute arbitrary system commands on the server, leading to full host compromise. Since all users can create courses by default, the risk is high.

Recommendation

Upgrade Chamilo LMS to version 1.11.38 or 2.0.0-RC.3. Consider restricting allow_users_to_create_courses to trusted users.

Other vulnerabilities in Chamilo LMS

See all
Original NVD description (English source)

Chamilo LMS is a learning management system. Prior to 1.11.38 and 2.0.0-RC.3, Chamilo LMS contains an OS Command Injection vulnerability in the file move function. The move() function in fileManage.lib.php passes user-controlled path values directly into exec() shell commands without using escapeshellarg(). When a user moves a document via document.php, the move_to POST parameter — which only passes through Security::remove_XSS() (an HTML-only filter) — is concatenated directly into shell commands such as exec("mv $source $target"). By default, Chamilo allows all authenticated users to create courses (allow_users_to_create_courses = true). Any user who is a teacher in a course (including self-created courses) can move documents, making this vulnerability exploitable by any authenticated user. The attacker must first place a directory with shell metacharacters in its name on the filesystem (achievable via Course Backup Import), then move a document into that directory to trigger arbitrary command execution as the web server user (www-data). This vulnerability is fixed in 1.11.38 and 2.0.0-RC.3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS