CVE-2026-32712
MediumCVSS 5.4Exploitation Probability (EPSS)
Low risk7th percentile - higher than 7% of all known CVEs
Summary
Open Source Point of Sale prior to version 3.4.3 has a stored XSS vulnerability in the Daily Sales management table. The customer_name column is rendered as raw HTML, allowing an attacker with customer management permissions to inject JavaScript via first_name or last_name fields.
Risk Assessment
The script executes in the browser of any user viewing the Daily Sales page, potentially leading to data or session theft.
Recommendation
Update Open Source Point of Sale to version 3.4.3 or later.
Other vulnerabilities in Open Source Point of Sale
See all- CVE-2026-19895Low
In the Open Source Point of Sale (opensourcepos) up to version 3.4.2, a vulnerability was found in the Login::index function in app/Config/Filters.php. The issue is improper restriction of excessive authentication attempts, allowing brute-force attacks. The attack is remote but requires high complexity. The exploit has been published, and the project has not responded.
- CVE-2026-8803Low
In opensourcepos Open Source Point of Sale up to 3.4.2, the Login function in app/Models/Employee.php (Employee Login component) uses a weak hash. Remote exploitation is possible but of high complexity; the vendor states the code remains for the upgrade path and passwords are migrated to a newer hash after login.
- CVE-2026-39380Medium
Stored XSS vulnerability in Open Source Point of Sale before version 3.4.3. Insufficient input sanitization in the stock_location parameter allows injection of malicious JavaScript that executes in the Employees interface.
- CVE-2025-68147High
In Open Source Point of Sale (opensourcepos) versions 3.4.0 through 3.4.1, there is a stored XSS vulnerability in the "Return Policy" configuration field. The application does not properly sanitize user input before saving it to the database or displaying it on receipts, allowing an attacker with access to store configuration to inject malicious JavaScript.
- CVE-2025-66924Medium
A Cross-site scripting (XSS) vulnerability in Create/Update Item Kit(s) in Open Source Point of Sale v3.4.1 allows remote attackers to inject arbitrary web script or HTML via the "name" parameter.
- CVE-2025-66923High
A Cross-site scripting (XSS) vulnerability in Create/Update Customer(s) in Open Source Point of Sale v3.4.1 allows remote attackers to inject arbitrary web script or HTML via the phone_number parameter.
- CVE-2025-66921High
A Cross-site scripting (XSS) vulnerability in Create/Update Item(s) Module in Open Source Point of Sale v3.4.1 allows remote attackers to inject arbitrary web script or HTML via the "name" parameter.
Original NVD description (English source)
Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Daily Sales management table. The customer_name column is configured with escape: false in the bootstrap-table column configuration, causing customer names to be rendered as raw HTML. An attacker with customer management permissions can inject arbitrary JavaScript into a customer's first_name or last_name field, which executes in the browser of any user viewing the Daily Sales page. This vulnerability is fixed in 3.4.3.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

