CVE Catalog

CVE-2026-31379

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.70%

52th percentile - higher than 52% of all known CVEs

Summary

Apache OFBiz before 24.09.06 contains Cross-site Scripting (XSS), Path Traversal, and Code Injection vulnerabilities due to improper input neutralization and pathname restrictions.

Risk Assessment

These vulnerabilities may allow an attacker to execute malicious scripts in a user's browser, access files outside the intended directory, or achieve remote code execution, potentially leading to system compromise.

Recommendation

Upgrade Apache OFBiz to version 24.09.06, which fixes these issues.

Other vulnerabilities in Apache OFBiz

See all
Original NVD description (English source)

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 24.09.06. Users are recommended to upgrade to version 24.09.06, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS