CVE-2026-27456
MediumCVSS 4.7Exploitation Probability (EPSS)
Low risk2th percentile - higher than 2% of all known CVEs
Summary
In util-linux prior to version 2.41.4, a TOCTOU vulnerability has been identified in the SUID binary /usr/bin/mount. When setting up loop devices, mount validates the source file path with user privileges but later re-canonicalizes and opens it with root privileges without verifying that the path has not been replaced. A local unprivileged user can replace the source file with a symlink pointing to any root-owned file or device.
Risk Assessment
An attacker can gain unauthorized read access to root-protected files and block devices, including backup images, disk volumes, and any file containing a valid filesystem. Exploitation requires an /etc/fstab entry with user,loop options and the SUID bit set on /usr/bin/mount.
Recommendation
Immediately update util-linux to version 2.41.4. Also review /etc/fstab entries and consider removing the SUID bit from /usr/bin/mount if not required.
Other vulnerabilities in util-linux
See all- CVE-2024-28085Low
wall in util-linux through 2.40, often installed with setgid tty permissions, allows escape sequences to be sent to other users' terminals through argv. Escape sequences from stdin are blocked, but those from argv are not.
- CVE-2014-9114High
Blkid in util-linux before version 2.26rc-1 allows local users to execute arbitrary code.
- CVE-2016-2779High
CVE-2016-2779 vulnerability in runuser in util-linux allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.
- CVE-2015-5224Critical
The mkostemp function in login-utils in util-linux, when used incorrectly, allows remote attackers to cause file name collision and possibly other attacks.
- CVE-2026-53615High
Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR.
- CVE-2026-53614High
In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges.
- CVE-2026-53613High
Vulnerability in util-linux versions 2.17 through 2.41.6, 2.42 through 2.42.3, and 2.42.4 when the legacy mount(2) path is used without /proc. Restricted non-root mount requests validate an /etc/fstab target before the mount operation re-resolves that pathname. A local low-privileged user authorized by an fstab user or users entry can use renameat2(RENAME_EXCHANGE) to swap a path component and redirect an authorized mount to a root-owned location, such as mounting attacker-controlled content over /etc/sudoers.d, thereby gaining root privileges.
- CVE-2026-53612High
Vulnerability in util-linux versions 2.39 through 2.41.4 and 2.42 through 2.42.1. The SUID mount utility's hook_owner.c post-mount hook performs path-based chmod() and lchown() operations on a previously validated mount target. A local low-privileged user authorized by an /etc/fstab entry with user or users and an X-mount.mode, X-mount.owner, or X-mount.group option can use renameat2(RENAME_EXCHANGE) to race a writable ancestor of the target and redirect the privileged ownership or mode change to a root-owned path, potentially gaining root privileges.
- CVE-2026-76642High
util-linux versions through 2.41.5 and 2.42.2 fail to check mount helper exit status before running post-mount hooks, allowing unprivileged users to execute privileged operations on pre-existing filesystems. Attackers can exploit X-mount.idmap or X-mount.owner hooks to clone filesystems with inherited suid bits or modify target inode permissions after a helper fails, achieving privilege escalation.
- CVE-2026-78410High
A flaw in util-linux: Restricted bind mounts take the source path from fstab but do not pin that source before the privileged mount. A local unprivileged user who can replace the authorized source or a writable ancestor can redirect SUID mount(8) to bind another host directory. If the fstab entry also sets X-mount.owner, X-mount.group, or X-mount.mode, root then changes ownership or mode on that redirected inode.
Original NVD description (English source)
util-linux is a random collection of Linux utilities. Prior to version 2.41.4, a TOCTOU (Time-of-Check-Time-of-Use) vulnerability has been identified in the SUID binary /usr/bin/mount from util-linux. The mount binary, when setting up loop devices, validates the source file path with user privileges via fork() + setuid() + realpath(), but subsequently re-canonicalizes and opens it with root privileges (euid=0) without verifying that the path has not been replaced between both operations. Neither O_NOFOLLOW, nor inode comparison, nor post-open fstat() are employed. This allows a local unprivileged user to replace the source file with a symlink pointing to any root-owned file or device during the race window, causing the SUID binary to open and mount it as root. Exploitation requires an /etc/fstab entry with user,loop options whose path points to a directory where the attacker has write permission, and that /usr/bin/mount has the SUID bit set (the default configuration on virtually all Linux distributions). The impact is unauthorized read access to root-protected files and block devices, including backup images, disk volumes, and any file containing a valid filesystem. This issue has been patched in version 2.41.4.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

