CVE-2026-27307
LowCVSS 2.4Exploitation Probability (EPSS)
High risk86th percentile - higher than 86% of all known CVEs
Summary
ColdFusion versions 2023.18, 2025.6 and earlier are affected by an Uncontrolled Resource Consumption vulnerability that could lead to application denial-of-service. A high-privileged attacker could exploit this vulnerability and exhaust system resources, reducing application speed. Exploitation of this issue does not require user interaction.
Risk Assessment
Exhaustion of system resources may cause ColdFusion application unavailability, impacting critical services and potentially leading to financial or operational losses.
Recommendation
Update ColdFusion to a version later than 2023.18 or 2025.6 that includes the fix, and monitor resource usage to detect potential attacks.
Other vulnerabilities in ColdFusion
See all- CVE-2026-75994Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. The vulnerable component is restricted to an administrative network zone by default. Exploitation of this issue does not require user interaction. Scope is changed.
- CVE-2026-106624Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106622Critical
ColdFusion is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106621Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction.
- CVE-2026-106620Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could bypass security measures and gain unauthorized write access. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106619Critical
ColdFusion is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation depends on conditions beyond the attacker's control and does not require user interaction, and the scope is changed.
- CVE-2026-106612Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105903Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105899Critical
ColdFusion is affected by an Unrestricted Upload of File with Dangerous Type vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-75746Critical
ColdFusion is affected by an SQL Injection vulnerability that could result in arbitrary code execution in the context of the current user. An attacker with high privileges could exploit this to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
Original NVD description (English source)
ColdFusion versions 2023.18, 2025.6 and earlier are affected by an Uncontrolled Resource Consumption vulnerability that could lead to application denial-of-service. A high-privileged attacker could exploit this vulnerability and exhaust system resources, reducing application speed. Exploitation of this issue does not require user interaction.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

