CVE-2026-25199
CriticalCVSS 9.1Exploitation Probability (EPSS)
Low risk43th percentile - higher than 43% of all known CVEs
Summary
In the Proxmox extension for Apache CloudStack, a non-privileged user can modify the proxmox_vmid setting to reference a VM belonging to another tenant. This allows unauthorized cross-tenant access and full control over the targeted VM, including starting, stopping, and destroying it.
Risk Assessment
Organizations using CloudStack with the Proxmox extension are exposed to takeover of other tenants' VMs, potentially leading to data leakage and service disruption.
Recommendation
Upgrade Apache CloudStack to version 4.22.0.1. As a workaround, add proxmox_vmid to the user.vm.denied.details parameter to prevent users from editing this field.
Other vulnerabilities in Apache CloudStack
See all- CVE-2026-62440Critical
Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. Affects versions from 4.21.0.0 through 4.22.1.0.
- CVE-2026-61398Critical
Improper Encoding or Escaping of Output vulnerability in Apache CloudStack's UI while using Instance Reset Password functionality. Affects versions from 4.15.1.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-59085Critical
Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. Affects versions from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2015-3252Critical
Apache CloudStack before version 4.5.2 does not properly preserve VNC passwords when migrating KVM virtual machines, allowing remote attackers to gain access by connecting to the VNC server.
- CVE-2026-59654High
Apache CloudStack versions 4.7.0 through 4.20.3.0 and 4.21.0.0 through 4.22.1.0 have a missing release of resource after effective lifetime vulnerability in the scoped global configuration functionality. This may lead to denial of service (DoS) for the management server.
- CVE-2026-68745High
Certificate validation failures in SAML authentication in Apache CloudStack 4.20.3.0 and 4.22.1.0 allow a malicious agent to forge a SAML response to the management server. The agent must spoof the IdP IP address or register a URL of its own choosing, after which it can allow logging on with forged signatures. Users are recommended to upgrade to versions 4.20.3.1 or 4.22.1.1 and above.
- CVE-2026-66797Medium
Improper access control in CloudStack's annotation functionality allows unauthorized comment creation and disclosure. The addAnnotation and listAnnotation APIs perform an ownership check but fail to honor its result correctly, allowing any authenticated user to write and read annotations on entities they don't own. Affects versions from 4.15.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-66722High
Improper authorization for CRUD operations on Project Roles and Project Role permissions for domain admins in CloudStack. A Domain Admin can create, update, delete, and list project roles and permissions for projects in any domain, not just their own. Affects versions from 4.15.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-66721Low
Missing authorization issue for domain admins in CloudStack's host tags listing functionality. Domain Admins have permission to call listHostTags API, but it returns host tags for every host without domain scoping. Affects versions from 4.12.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
- CVE-2026-65613Medium
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's Webhook module while listing and deleting deliveries. Affects versions from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.
Original NVD description (English source)
Instances deployed via the Proxmox extension allow unauthorized access to instances belonging to other tenants. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.0.0. The Proxmox extension for CloudStack improperly uses a user-editable instance setting, proxmox_vmid, to associate CloudStack instances with Proxmox virtual machines. Because this value is not restricted or validated against tenant ownership and Proxmox VM IDs are predictable, a non-privileged attacker can modify the setting to reference a VM belonging to another account. This allows unauthorized cross-tenant access and enables full control over the targeted VM, including starting, stopping, and destroying the virtual machine. Users are recommended to upgrade to version 4.22.0.1, which fixes this issue. As a workaround for the existing installations, editing of the proxmox_vmid instance detail by users can be prevented by adding this detail name to the global configuration parameter - user.vm.denied.details.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

