CVE-2026-19898
LowCVSS 3.7Exploitation Probability (EPSS)
Low risk40th percentile - higher than 40% of all known CVEs
Summary
In VictoriaMetrics up to version 1.146.0, a vulnerability was found in the VMAuth Authentication Endpoint component, in the requestHandler function of app/vmauth/main.go. The issue is improper restriction of excessive authentication attempts, allowing brute-force attacks. The attack is remote but requires high complexity. Upgrading to version 1.147.0 is recommended.
Risk Assessment
Lack of login attempt restrictions can allow an attacker to perform brute-force attacks on passwords, potentially leading to unauthorized access to the system.
Recommendation
Upgrade VictoriaMetrics to version 1.147.0 or later, which includes the fix.
Other vulnerabilities in VictoriaMetrics
See all- CVE-2026-61625Medium
VictoriaMetrics is a scalable solution for monitoring and managing time series data. Prior to 1.122.25, 1.136.12, and 1.146.0, vmrestore does not validate backup part path components before using lib/backup/actions/restore.go and lib/backup/fslocal/fslocal.go to write restored data below storageDataPath. An attacker who can supply or modify an S3, GCS, Azure Blob Storage, or other backup source can place .. components in object names. When an operator restores that source, the crafted names can create or overwrite files outside the intended restore root within the filesystem permissions of the vmrestore process. This issue is fixed in versions 1.122.25, 1.136.12, and 1.146.0.
- CVE-2025-65942Low
VictoriaMetrics in versions from 1.0.0 before 1.110.23, from 1.111.0 before 1.122.8, and from 1.123.0 before 1.129.1 is vulnerable to DoS attacks because the snappy decoder ignored request size limits, allowing malformed blocks to trigger excessive memory use. This could lead to OOM errors and service instability; the fix enforces block-size checks based on MaxRequest limits and is available in versions 1.110.23, 1.122.8, and 1.129.1.
Original NVD description (English source)
A vulnerability was found in VictoriaMetrics up to 1.146.0. Impacted is the function requestHandler of the file app/vmauth/main.go of the component VMAuth Authentication Endpoint. Performing a manipulation results in improper restriction of excessive authentication attempts. The attack is possible to be carried out remotely. The complexity of an attack is rather high. The exploitability is considered difficult. The exploit has been made public and could be used. Upgrading to version 1.147.0 is recommended to address this issue. The patch is named 119ba0fb5be8024d50c5ba946599b2e69e8803ea. Upgrading the affected component is recommended.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

