CVE-2026-19858
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk24th percentile - higher than 24% of all known CVEs
Summary
The JetFormBuilder — Dynamic Blocks Form Builder WordPress plugin before version 3.6.5.2 does not perform authorisation checks when resolving request-derived data during page rendering. This allows unauthenticated users to read arbitrary user, post and term properties and metadata, including password hashes, private and draft content, and secrets stored in metadata by the plugin.
Risk Assessment
The organization is at risk of sensitive data leakage, such as password hashes and private content, potentially leading to confidentiality breaches and privilege escalation.
Recommendation
Immediately update the JetFormBuilder plugin to version 3.6.5.2 or later to remediate the missing authorization.
Other vulnerabilities in JetFormBuilder
See all- CVE-2026-107431High
A Missing Authorization vulnerability in Crocoblock JetFormBuilder allows exploiting incorrectly configured access control security levels. Affects versions up to 3.6.6.
- CVE-2026-119480Medium
The JetFormBuilder plugin (Crocoblock) contains a Path Traversal vulnerability due to improper limitation of a pathname to a restricted directory. The issue affects versions up to and including 3.6.7.1.
- CVE-2026-119479Medium
The JetFormBuilder plugin (Crocoblock) through 3.6.7.1 contains a Basic XSS vulnerability due to improper neutralization of script-related HTML tags. This can lead to code injection in the page context.
- CVE-2026-119482Medium
Missing Authorization vulnerability in Crocoblock JetFormBuilder jetformbuilder allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects JetFormBuilder: from n/a through 3.6.7.1.
- CVE-2026-103912Medium
The JetFormBuilder plugin for WordPress up to version 3.6.6 is vulnerable to Reflected DOM-Based XSS via a query parameter matching the preset's query_var setting. Exploitation requires a form with a text field configured with a query_var Dynamic Preset and a macro reference.
- CVE-2026-102391High
Unauthenticated Cross Site Scripting (XSS) in JetFormBuilder versions <= 3.6.5.4.
- CVE-2026-19860Medium
The JetFormBuilder — Dynamic Blocks Form Builder WordPress plugin before 3.6.5.3 does not sufficiently restrict which PHP functions can be used as a custom field-validation callback, relying on a blocklist that omits a file-deletion function, allowing users able to manage forms to cause arbitrary files on the server to be deleted. The deletion itself is carried out when the form is submitted, which requires no authentication.
- CVE-2026-84817High
Unauthenticated Cross Site Scripting (XSS) vulnerability in JetFormBuilder versions up to 3.6.5.1. Allows an attacker to inject malicious script into a page, which executes in the victim's browser.
- CVE-2026-19859Medium
The JetFormBuilder WordPress plugin before 3.6.5.2 does not sanitize a request parameter before rendering it as message content, allowing unauthenticated users to execute arbitrary shortcodes registered on the site on any page displaying a form. Escaping is applied to that content before a later shortcode-expansion pass rather than after it, so the escaping can be bypassed.
- CVE-2026-19861Medium
The JetFormBuilder — Dynamic Blocks Form Builder WordPress plugin before version 3.6.5.2 does not properly sanitise and escape a form field's value before including it in HTML notification emails. This allows unauthenticated users to inject arbitrary HTML into messages delivered to administrators and other recipients. Whether injected script executes depends on the recipient's mail client, but the injected markup is rendered regardless.
Original NVD description (English source)
The JetFormBuilder — Dynamic Blocks Form Builder WordPress plugin before 3.6.5.2 does not perform authorisation checks when resolving request-derived data during page rendering, allowing unauthenticated users to read arbitrary user, post and term properties and metadata, including password hashes, private and draft content, and secrets other JetFormBuilder — Dynamic Blocks Form Builder WordPress plugin before 3.6.5.2 store in metadata.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

