CVE-2026-19423
HighCVSS 8.1Exploitation Probability (EPSS)
Low risk20th percentile - higher than 20% of all known CVEs
Summary
The Ultimate Member WordPress plugin before version 2.13.0 does not validate a submitted role selection when it cannot resolve the set of roles a profile form permits, and screens the value against the site's registered role names rather than against the form's own allow-list. This allows unauthenticated users who register through the plugin's own form to grant themselves arbitrary capabilities and reach administrator-equivalent access.
Risk Assessment
An attacker could gain full control of the site by granting themselves administrator privileges, leading to complete takeover.
Recommendation
Update the Ultimate Member plugin to version 2.13.0 or later, which includes the role validation fix.
Other vulnerabilities in Ultimate Member WordPress plugin
See all- CVE-2023-3460Critical
The Ultimate Member WordPress plugin before version 2.6.7 does not prevent visitors from creating user accounts with arbitrary capabilities, effectively allowing attackers to create administrator accounts at will.
- CVE-2026-107625Medium
The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'user_url' parameter in all versions up to, and including, 2.14.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires a visitor to click the attacker's Website URL link on their public Ultimate Member profile, a condition that is trivially met since the redirect-confirmation onclick handler is enabled by default on all new installations.
- CVE-2025-13220Medium
The Ultimate Member plugin for WordPress in versions up to and including 2.11.0 is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode attributes due to insufficient input sanitization and output escaping. This allows authenticated attackers with Contributor-level access or higher to inject arbitrary web scripts into pages.
Original NVD description (English source)
The Ultimate Member WordPress plugin before 2.13.0 does not validate a submitted role selection when it cannot resolve the set of roles a profile form permits, and screens the value against the site's registered role names rather than against the form's own allow-list, allowing unauthenticated users who register through the Ultimate Member WordPress plugin before 2.13.0's own form to grant themselves arbitrary capabilities and reach administrator-equivalent access.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

