CVE-2026-18202
MediumCVSS 6.8Exploitation Probability (EPSS)
Low risk36th percentile - higher than 36% of all known CVEs
Summary
The JetEngine WordPress plugin before 3.8.14 adds SVG to the site-wide list of allowed upload types without sanitizing file contents, allowing users with upload capability, such as Authors, to upload files containing malicious JavaScript that executes in the browser of any user who opens it (Stored XSS). On multisite, this also overrides an upload-type restriction set by the network administrator.
Risk Assessment
Malicious JavaScript can steal user data, hijack sessions, or spread malware.
Recommendation
Update the JetEngine plugin to version 3.8.14 or later, which includes SVG sanitization fixes.
Other vulnerabilities in JetEngine
See all- CVE-2026-39735Medium
The JetEngine plugin by Crocoblock (up to version 3.9.0.1) contains a missing authorization vulnerability, allowing exploitation of incorrectly configured access control security levels.
- CVE-2026-115608High
The Crocoblock JetEngine WordPress plugin in versions up to 3.9.0 contains an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. This may allow an attacker to inject malicious SQL code.
- CVE-2026-97238Medium
Cross Site Scripting (XSS) vulnerability in JetEngine up to version 3.8.14.3. A subscriber can inject malicious scripts.
- CVE-2026-66613Critical
Unauthenticated remote code execution (RCE) vulnerability in JetEngine plugin versions up to and including 3.8.14. An attacker can execute arbitrary code on the server without logging in.
- CVE-2026-56068Critical
The JetEngine plugin for WordPress versions 3.8.10.2 and earlier contains an SQL injection vulnerability that can be exploited by an unauthenticated attacker. This vulnerability allows unauthorized database queries to be executed.
- CVE-2026-54187Critical
There is an unauthenticated SQL injection vulnerability in JetEngine versions <= 3.8.10.1.
- CVE-2026-52706Critical
There is an unauthenticated PHP object injection vulnerability in JetEngine versions up to 3.8.10.
- CVE-2026-49084Critical
JetEngine versions below 3.8.9.1 are vulnerable to unauthenticated SQL injection.
- CVE-2026-49076Critical
The Crocoblock JetEngine plugin for WordPress up to version 3.8.9.1 contains an SQL Injection vulnerability due to improper neutralization of special elements in SQL commands. This allows an attacker to perform Blind SQL Injection.
- CVE-2026-49075Critical
JetEngine versions up to 3.8.9.1 are vulnerable to PHP Object Injection, which may lead to unauthorized access to data.
Original NVD description (English source)
The JetEngine WordPress plugin before 3.8.14 adds SVG to the site-wide list of allowed upload types without sanitising the file contents, allowing users with the upload files capability, such as Authors, to upload a file containing malicious JavaScript that executes in the browser of any user who opens it (Stored Cross-Site Scripting). On multisite, this also overrides an upload-type restriction set by the network administrator.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

