CVE-2026-17149
MediumCVSS 6.4Exploitation Probability (EPSS)
Low risk11th percentile - higher than 11% of all known CVEs
Summary
The myCred plugin for WordPress (up to and including version 3.2.4) is vulnerable to Stored Cross-Site Scripting via the 'wrapper' shortcode attribute due to insufficient input sanitization and output escaping. Authenticated attackers with contributor-level access can inject arbitrary web scripts that execute when a user accesses an injected page.
Risk Assessment
The risk of malicious script execution in users' browsers could lead to session theft, defacement, or other attacks.
Recommendation
Update the plugin to a version newer than 3.2.4 if available, and restrict contributor permissions to trusted individuals.
Other vulnerabilities in myCred
See all- CVE-2026-115962Medium
The myCred plugin contains an authentication bypass by spoofing vulnerability that allows identity spoofing. The issue affects versions from n/a through 4.0.1.
- CVE-2026-97073Medium
Missing Authorization vulnerability in the myCred (mycred) plugin allows exploitation of incorrectly configured access control security levels. This issue affects myCred from n/a through 4.0.2.
- CVE-2026-114698Medium
The myCred plugin is vulnerable to authorization bypass through a user-controlled key, allowing exploitation of incorrectly configured access control security levels. This affects versions up to and including 4.0.0-beta.1.
- CVE-2026-15150Medium
The myCred WordPress plugin before 3.2.5 does not verify that the receiver of an incoming payment gateway notification matches the site's configured merchant account, allowing unauthenticated attackers to have arbitrary amounts of the site's in-site currency credited to an account by completing a payment for the expected amount to a gateway account they control rather than the site's.
- CVE-2026-61968Medium
The myCred WordPress plugin contains a missing authorization vulnerability that allows exploiting incorrectly configured access control security levels. This issue affects versions up to and including 3.1.2.
- CVE-2026-40794Medium
Versions of myCred up to 3.0.3 have a vulnerability in access control, allowing unauthorized access to subscriber resources.
- CVE-2026-42676Medium
The myCred plugin is vulnerable to Stored Cross-Site Scripting (XSS) in all versions up to and including 3.0.4. Improper neutralization of input during web page generation allows attackers to inject malicious scripts that are then executed in other users' browsers.
- CVE-2025-12362Medium
The myCred – Points Management System For Gamification, Ranks, Badges, and Loyalty Program plugin for WordPress is vulnerable to Missing Authorization in versions up to and including 2.9.7. This is due to the plugin not properly verifying that a user is authorized to perform an action, allowing unauthenticated attackers to approve withdrawal requests, modify user point balances, and manipulate the payment processing system via the cashcred_pay_now AJAX action.
Original NVD description (English source)
The Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'wrapper' Shortcode Attribute in all versions up to, and including, 3.2.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

