CVE-2026-16584
HighCVSS 7.0Exploitation Probability (EPSS)
Low risk13th percentile - higher than 13% of all known CVEs
Summary
Improper handling of an initialization failure in AWS API MCP Server versions 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny. When initialization of security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect.
Risk Assessment
An attacker can bypass the security policy and execute unauthorized AWS API operations, potentially compromising the confidentiality, integrity, or availability of AWS resources.
Recommendation
Upgrade AWS API MCP Server to version 1.3.47 or later, which includes a fix.
Other vulnerabilities in AWS API MCP Server
Original NVD description (English source)
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

