CVE-2026-16535
MediumCVSS 6.1Exploitation Probability (EPSS)
Low risk6th percentile - higher than 6% of all known CVEs
Summary
The Link Library WordPress plugin before version 7.9.4 does not sanitise and escape a parameter before reflecting it back in a response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting attacks against users who can be tricked into performing an action.
Risk Assessment
An attacker can execute malicious script in the victim's browser, potentially leading to session theft, account takeover, or unauthorized actions in the context of the logged-in user.
Recommendation
Update the Link Library plugin to version 7.9.4 or later, which includes the sanitization and escaping fix. Additionally, educate users about the risk of clicking suspicious links.
Other vulnerabilities in Link Library
See all- CVE-2026-18855Critical
The Link Library plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the ll_delete_link_fields function in all versions up to, and including, 7.9.4. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). Exploitation requires the administrator to have enabled the 'Delete local file on link deletion' plugin option (disabled by default) and to subsequently permanently delete the attacker-submitted link, which is a routine moderation action.
- CVE-2026-16532Critical
The 'Link Library' WordPress plugin before version 7.9.3 does not properly sanitize and escape a user-supplied value before using it in a SQL query, allowing unauthenticated users to perform SQL injection attacks.
- CVE-2026-78392Medium
The Link Library WordPress plugin before 7.9.6 does not sanitise and escape a link field before outputting it inside an attribute of a link preview, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks. The preview is generated without authentication and without checking whether the link has been published, so an unapproved submission is enough to reach any visitor who opens it.
- CVE-2026-15090High
The Link Library plugin for WordPress is vulnerable to time-based SQL Injection via the 'link_url' parameter in all versions up to, and including, 7.9.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
- CVE-2026-40779High
In Link Library versions <= 7.8.8, there is a vulnerability allowing arbitrary file deletion by users with appropriate permissions.
- CVE-2025-68600Medium
The Yannick Lefebvre WordPress Link Library plugin (link-library) contains a Server-Side Request Forgery (SSRF) vulnerability. This issue affects versions from n/a through 7.8.7. The vulnerability may allow an attacker to force the server to make requests to arbitrary resources.
Original NVD description (English source)
The Link Library WordPress plugin before 7.9.4 does not sanitise and escape a parameter before reflecting it back in a response, allowing unauthenticated attackers to perform Reflected Cross-Site Scripting attacks against users who can be tricked into performing an action.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

