CVE-2026-15158
CriticalCVSS 9.8Exploitation Probability (EPSS)
Elevated risk58th percentile - higher than 58% of all known CVEs
Summary
The Blocksy Companion plugin for WordPress is vulnerable to arbitrary file upload in versions up to 2.1.46. The flaw lies in the save_attachments function, which improperly validates file extensions, allowing double-extension files like shell.woff2.php to bypass MIME checks. This can lead to remote code execution, but exploitation requires the premium plugin with specific extensions active.
Risk Assessment
An unauthenticated attacker could upload a malicious file and achieve remote code execution, compromising the server's confidentiality, integrity, and availability.
Recommendation
Update Blocksy Companion to version 2.1.47 or later immediately. If using the premium version, ensure WooCommerce Extra and Custom Fonts extensions are updated or temporarily disable them.
Other vulnerabilities in Blocksy Companion
See all- CVE-2026-97247Medium
Unauthenticated Broken Access Control vulnerability in Blocksy Companion versions up to 2.1.55.
- CVE-2026-107645Critical
The Blocksy Companion plugin up to version 2.1.58 is vulnerable to privilege escalation. The implement_user_registration() AJAX handler disables Dokan's vendor-registration nonce check and trusts an attacker-supplied $_POST['role'] value, allowing unauthenticated attackers to obtain a Dokan 'seller' account and be auto-authenticated, even when vendor signup is disabled.
- CVE-2026-65444Medium
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Creative Themes Blocksy Companion blocksy-companion allows Stored XSS. This issue affects Blocksy Companion: from n/a through 2.1.60.
- CVE-2026-18488Medium
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'tagName' block attribute in all versions up to and including 2.1.51. Authenticated attackers with author-level access or higher can inject arbitrary web scripts that execute whenever a user accesses an injected page.
- CVE-2025-12475Medium
The Blocksy Companion plugin for WordPress (up to 2.1.14) is vulnerable to Stored XSS via the 'blocksy_newsletter_subscribe' shortcode due to insufficient input sanitization and output escaping.
Original NVD description (English source)
The Blocksy Companion plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.1.46 via the save_attachments function. This is due to the Custom Fonts extension registering a wp_check_filetype_and_ext filter that approves any filename containing .woff2 or .ttf as a substring via strpos() rather than validating that those strings appear as the final extension via PATHINFO_EXTENSION — allowing double-extension filenames such as shell.woff2.php to pass MIME validation and be handled as permitted font files. This makes it possible for unauthenticated attackers to upload files that may be executable, which makes remote code execution possible. This vulnerability is only exploitable when the premium version of the plugin (blocksy-companion-pro) is installed with both the WooCommerce Extra (Advanced Reviews) and Custom Fonts extensions active; the free blocksy-companion plugin does not contain the vulnerable code paths.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

