CVE-2026-14845
MediumCVSS 6.1Exploitation Probability (EPSS)
Low risk6th percentile - higher than 6% of all known CVEs
Summary
The NewStatPress WordPress plugin before version 1.4.5 does not sanitize and escape data from unauthenticated visitor requests before storing and later outputting it in one of its widgets. This allows unauthenticated attackers to perform Stored Cross-Site Scripting attacks against users viewing the affected widget.
Risk Assessment
An attacker can inject a malicious script that executes in the browsers of administrators and visitors, leading to session theft, redirects to malicious sites, or data theft.
Recommendation
Update the NewStatPress plugin to version 1.4.5 or later.
Other vulnerabilities in NewStatPress
See all- CVE-2026-101924High
The NewStatPress plugin for WordPress up to version 1.4.5 is vulnerable to Stored Cross-Site Scripting via the 'Last referrers' meta box on the Overview admin page due to insufficient output escaping, allowing unauthenticated attackers to inject arbitrary scripts.
- CVE-2026-100153High
The NewStatPress plugin for WordPress in versions up to and including 1.4.5 is vulnerable to Stored Cross-Site Scripting via the 'QUERY_STRING / REQUEST_URI' parameter. Due to insufficient input sanitization and output escaping, an unauthenticated attacker can inject arbitrary scripts into pages that execute when a user visits the injected page. Exploitation requires that an administrator has placed the [NewStatPress type="Top Pages"] shortcode on a publicly viewable page, and that the attacker's crafted URL accumulates enough hits to appear in the top-N ranking.
- CVE-2025-13747Medium
The NewStatPress plugin for WordPress in versions up to and including 1.4.3 is vulnerable to Stored Cross-Site Scripting via a regex bypass in the `nsp_shortcode` function due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts that execute when a user visits the injected page.
Original NVD description (English source)
The NewStatPress WordPress plugin before 1.4.5 does not sanitise and escape data derived from unauthenticated visitor requests before storing it and later outputting it in one of its widgets, which could allow unauthenticated attackers to perform Stored Cross-Site Scripting attacks against users viewing the affected widget.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

