CVE-2026-12724
MediumCVSS 4.3Exploitation Probability (EPSS)
Low risk1th percentile - higher than 1% of all known CVEs
Summary
The Kirki WordPress plugin before version 6.0.12 does not sanitize or escape the email subject and body values supplied in a request before including them in the password-reset email sent as HTML. This allows unauthenticated users to inject arbitrary HTML into the message delivered to a registered user, which can be used for phishing.
Risk Assessment
An attacker can craft a password reset request that sends an email with arbitrary HTML, such as a fake login form, to the victim. This increases the risk of credential theft and WordPress user account compromise.
Recommendation
Immediately update the Kirki plugin to version 6.0.12 or later. If an update is not possible, consider temporarily disabling the plugin until it can be updated.
Other vulnerabilities in Kirki
See all- CVE-2026-13147Critical
The Kirki WordPress plugin before version 6.0.12 does not validate a user-supplied URL before requesting it server-side, allowing unauthenticated attackers to make the site issue HTTP requests to arbitrary hosts (Server-Side Request Forgery).
- CVE-2026-57726Critical
The Kirki plugin for WordPress contains a Blind SQL Injection vulnerability in versions up to and including 6.0.12. The issue is due to improper neutralization of special elements used in SQL commands.
- CVE-2026-57724Critical
The Kirki WordPress plugin contains a deserialization of untrusted data vulnerability allowing object injection. This affects versions up to and including 6.0.12.
- CVE-2026-112348Medium
The Kirki plugin for WordPress before 6.2.5 contains a reCAPTCHA bypass vulnerability. Unauthenticated attackers can submit frontend forms without valid verification by omitting the g-recaptcha-token field in POST requests, because the verify() method returns early on empty token values.
- CVE-2026-42694Medium
The Kirki WordPress plugin in versions up to 6.4.0 contains an Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability that allows code injection. The issue affects versions from n/a through 6.4.0.
- CVE-2026-107762High
The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress in versions up to and including 6.3.2 is vulnerable to Insecure Direct Object Reference via the 'context' parameter due to missing validation on a user-controlled key. This allows unauthenticated attackers to expose arbitrary users' sensitive profile data, including email address, display name, registration date, profile image URL, and user meta fields.
- CVE-2026-104734High
The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress in versions up to and including 6.3.2 is vulnerable to PHP Object Injection via deserialization of untrusted input. This allows authenticated attackers with administrator-level access and above to inject a PHP Object; by default, Editor-level users are granted FULL_ACCESS to the plugin's import endpoint.
- CVE-2026-14572Medium
The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Page Builder Text Content in all versions up to, and including, 6.2.0 due to insufficient input sanitization and output escaping.
- CVE-2026-102291Medium
The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to and including 6.3.1. This is due to the plugin substituting a user's display_name into the composed page markup unfiltered and then running the whole result through do_shortcode().
- CVE-2026-103065High
Improper validation of specified quantity in input in Kirki up to version 6.3.1. Allows accessing functionality not properly constrained by ACLs.
Original NVD description (English source)
The Kirki WordPress plugin before 6.0.12 does not sanitise or escape the email subject and body values supplied in a request before including them in the password-reset email it sends as HTML, allowing unauthenticated users to inject arbitrary HTML into the message delivered to a registered user, which can be used for phishing.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

