CVE Catalog

CVE-2026-120135

HighCVSS 8.2
Published: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.55%

46th percentile - higher than 46% of all known CVEs

Summary

An uncontrolled recursion vulnerability exists in the Apache Thrift Java bindings. The issue affects Apache Thrift versions before 0.24.0. It is fixed in version 0.24.0.

Risk Assessment

Processing specially crafted input can trigger uncontrolled recursion, leading to resource exhaustion and denial of service. The risk applies to applications using vulnerable versions of the Thrift Java libraries.

Recommendation

Upgrade Apache Thrift to version 0.24.0 or later. After upgrading, verify that all dependent applications use the fixed library version.

Other vulnerabilities in Apache Thrift

See all
Original NVD description (English source)

Uncontrolled Recursion vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS