CVE Catalog

CVE-2026-118057

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.24%

15th percentile - higher than 15% of all known CVEs

Summary

The Shield Security plugin for WordPress (up to 22.3.2) is vulnerable to Stored Cross-Site Scripting via the 'REQUEST_URI' parameter. Insufficient input sanitization and output escaping allow unauthenticated attackers to inject arbitrary scripts that execute when a user visits an injected page. The hidden 'path' column in ForTraffic.php is unescaped, enabling the attack.

Risk Assessment

An attacker can execute arbitrary JavaScript in the browser of a user visiting the infected page, potentially leading to session theft or other actions in the site context. This requires only unauthenticated access to the site.

Recommendation

Update the plugin to a version later than 22.3.2. Until then, consider disabling the plugin or applying WAF rules to block suspicious REQUEST_URI values.

Related vulnerabilities

Original NVD description (English source)

The Shield Security – Smart Bot Blocking, Brute-Force Login Protection & File Scanning plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'REQUEST_URI' parameter in all versions up to, and including, 22.3.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The hidden 'path' column in ForTraffic.php lacks a client-side render function, so DataTables builds its cell via innerHTML, causing stored HTML in the path value to be parsed into live DOM nodes; a prior partial fix in version 18.5.8 added esc_html() only to the visible 'page' column, leaving the hidden 'path' field unescaped and exploitable through version 22.2.6.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS