CVE Catalog

CVE-2026-117518

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Summary

@fastify/reply-from versions up to and including 12.8.0 validate proxy paths only against forward-slash dot-segments, then build the target with the WHATWG URL parser, which normalizes backslash and its percent-encoded form to a forward slash. A path using backslash dot-segments bypasses the traversal check and resolves to a different upstream path. An unauthenticated request can escape the intended prefix and reach other upstream endpoints.

Risk Assessment

An attacker can access unintended upstream resources, primarily impacting confidentiality with limited integrity impact. The risk affects applications scoping proxying to an upstream prefix or relying on route guards.

Recommendation

Upgrade @fastify/reply-from to version 12.8.1 or later. There is no workaround other than upgrading.

Other vulnerabilities in @fastify/reply-from

See all
Original NVD description (English source)

@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP server. In versions up to and including 12.8.0, the plugin validated proxy paths against forward-slash dot-segments only and then built the target with the WHATWG URL parser, which normalizes a backslash and its percent-encoded form to a forward slash on the http, https, ws, and wss schemes. A path that uses backslash dot-segments therefore bypasses the traversal check and resolves to a different upstream path, so an application that scopes proxying to an upstream prefix, or relies on route guards in front of the forwarding call, can have an unauthenticated request escape the intended prefix and reach other upstream endpoints. The resulting access to unintended upstream resources is primarily a confidentiality impact with limited integrity impact. The issue is fixed in @fastify/reply-from 12.8.1, where the path is normalized and any segment resolving to a single or double dot, along with control characters and ambiguous whitespace, is rejected before the URL is constructed, and users should upgrade to 12.8.1 or later. There is no workaround other than upgrading.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS