CVE Catalog

CVE-2026-116675

HighCVSS 8.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.35%

28th percentile - higher than 28% of all known CVEs

Summary

TinyMCE versions 7.9.3 through 7.9.4 and 8.5.1 through 8.9.3 contain a stored XSS vulnerability in the media plugin. Elements crafted via data-mce-object can execute malicious scripts during processing before sanitization. The issue is fixed in 8.9.3 and 7.9.4.

Risk Assessment

Users with the media plugin enabled could be targeted by XSS, leading to session theft or actions performed on their behalf. The risk affects applications using vulnerable editor versions.

Recommendation

Update TinyMCE to version 8.9.3 or 7.9.4 (or later). Until patched, disable the media plugin or restrict user content insertion.

Other vulnerabilities in TinyMCE

See all
Original NVD description (English source)

TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS