CVE-2026-116004
LowCVSS 3.5Exploitation Probability (EPSS)
Low risk10th percentile - higher than 10% of all known CVEs
Summary
A security vulnerability was detected in onyx-dot-app Onyx up to version 5.0.0. It affects an unknown function in web/src/app/craft/components/output-panel/PreviewTab.tsx and leads to cross-site scripting (XSS). The attack can be initiated remotely, and the exploit has been publicly disclosed.
Risk Assessment
The XSS vulnerability may allow an attacker to execute malicious script in a user's browser, risking session or data theft. The public availability of the exploit increases the risk of exploitation.
Recommendation
Update Onyx to a version containing the fix, or implement appropriate security headers and input validation. Until updated, consider restricting access to the vulnerable component.
Other vulnerabilities in Onyx
See all- CVE-2026-71424Critical
Onyx is an open-source AI platform. Prior to 3.1.10, 3.2.14, and 4.0.0, Onyx's GET /api/mcp/servers and GET /api/mcp/servers/persona/{persona_id} endpoints expose another user's OAuth Authorization header because OnyxTokenStorage.set_tokens and OnyxTokenStorage.set_client_info in backend/onyx/server/features/mcp/api.py copy per-user tokens into a shared admin MCPConnectionConfig row and _db_mcp_server_to_api_mcp_server returns that row through auth_template.headers to any BASIC_ACCESS user. This issue is fixed in versions 3.1.10, 3.2.14, and 4.0.0.
- CVE-2026-85700Medium
Onyx 4.6.6 fails to properly restrict access to custom tool credentials stored in custom_headers, allowing any authenticated user to read admin-defined API keys. Attackers with basic authentication can call GET /tool/{tool_id} or GET /tool endpoints to retrieve plaintext authorization headers and third-party API credentials, then use them to directly access upstream APIs.
- CVE-2026-63178Medium
Onyx is an open-source AI platform. Prior to 4.3.0, the Enterprise Edition lacks enforcement of curator permission validation in the PATCH /manage/admin/user-group/{user_group_id} and POST /manage/admin/user-group/{user_group_id}/add-users endpoints, allowing a curator to add accounts to arbitrary groups and gain document access. This is fixed in version 4.3.0.
Original NVD description (English source)
A security vulnerability has been detected in onyx-dot-app Onyx up to 5.0.0. Impacted is an unknown function of the file web/src/app/craft/components/output-panel/PreviewTab.tsx. The manipulation leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

