CVE-2026-115981
LowCVSS 2.4Exploitation Probability (EPSS)
Low risk17th percentile - higher than 17% of all known CVEs
Summary
A security vulnerability was detected in phpIPAM up to 1.8.3 in an unknown functionality of upgrade/index.php. Manipulation of the REQUEST_URI argument leads to cross site scripting. The attack can be launched remotely and the exploit has been publicly disclosed.
Risk Assessment
An attacker could remotely execute malicious script in the context of a phpIPAM user's browser, risking session hijacking or unauthorized actions. The public availability of the exploit increases the risk of exploitation.
Recommendation
Update phpIPAM to a version newer than 1.8.3 once the vendor provides a fix and ensure validation of the REQUEST_URI argument. Until then, restrict access to upgrade/index.php and the phpIPAM interface.
Other vulnerabilities in phpIPAM
See all- CVE-2026-67602Critical
phpIPAM before 1.8.2 contains an authentication bypass vulnerability in the REST API that allows unauthenticated attackers to gain full API access by exploiting an insecure object cache keying mechanism. The cache is keyed by lookup value alone without including the searched column, enabling an entry written during an app_id lookup to satisfy a subsequent app_code lookup, allowing attackers to use the numeric database row identifier as an API token to read, write, and delete all IP address management records.
- CVE-2026-115982Medium
A vulnerability was detected in phpIPAM up to 1.8.3 in the create_rack_link function of app/tools/racks/show-rack-popup.php (Rack Link Creation component). Manipulation of the deviceid argument results in cross site scripting. The issue can be exploited remotely and a public exploit is already available.
- CVE-2026-108720Medium
phpIPAM through 1.8.3 contains a missing authorization vulnerability that allows authenticated low-privilege users to view restricted subnets and addresses because customer, location and NAT pages skip Subnets::check_permission. Attackers can open customer objects.php, single-location.php or nat_details.php to read IP addresses, CIDRs, hostnames and MAC addresses from sections they cannot access.
- CVE-2026-97818High
phpIPAM through 1.8.3 has incorrect authorization for id=="admins" and id=="all" in api/controllers/User.php. This flaw allows access to functionality that should be restricted to authorized users.
- CVE-2026-75105High
phpIPAM through 1.8.1 fails to verify that a requested IP address belongs to the subnet a temporary share token was issued for. In app/temp_share/index.php and app/temp_share/address.php, when the share type is 'subnets', the subnetId parameter is used directly as a database primary key to fetch an address without confirming the address belongs to the authorized subnet. An unauthenticated party holding any valid, non-expired temporary share URL can enumerate the subnetId parameter to read every IP address record across all sections and subnets, including hostnames, DNS names, MAC addresses, owner/contact fields, and notes (which may contain credentials and configuration details).
- CVE-2026-12194Low
PHPIPAM is affected by an authenticated local file inclusion vulnerability that allows users with access to the API to execute/include arbitrary PHP files on the web server's file system. The API is not enabled by default on installations.
- CVE-2025-61078Medium
A cross-site scripting (XSS) vulnerability was found in phpIPAM v1.7.3 in the Request IP form. It allows remote attackers to inject arbitrary web script or HTML via the instructions parameter at the /app/admin/instructions/edit-result.php endpoint.
- CVE-2025-60912Low
phpIPAM v1.7.3 contains a Cross-Site Request Forgery (CSRF) vulnerability in the database export functionality. The generate-mysql.php function, located in the /app/admin/import-export/ endpoint, allows remote attackers to trigger large database dump downloads via crafted HTTP GET requests if an administrator has an active session.
Original NVD description (English source)
A security vulnerability has been detected in phpIPAM up to 1.8.3. Affected by this vulnerability is an unknown functionality of the file upgrade/index.php. Such manipulation of the argument REQUEST_URI leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

