CVE-2026-11579
MediumCVSS 5.3Exploitation Probability (EPSS)
Low risk15th percentile - higher than 15% of all known CVEs
Summary
The Kali Forms WordPress plugin before version 2.4.17 does not verify that a file upload is associated with an existing form configured with a file-upload field, allowing unauthenticated users to upload files to the WordPress Media Library. Uploads are limited to default-allowed MIME types, so code execution is not possible.
Risk Assessment
The risk involves unauthorized users cluttering the media library, potentially exhausting server storage or using uploaded files in social engineering attacks.
Recommendation
Immediately update the Kali Forms plugin to version 2.4.17 or later, which includes a fix for this vulnerability.
Other vulnerabilities in Kali Forms
See all- CVE-2026-48196Medium
The Kali Forms plugin for WordPress contains a Stored XSS vulnerability due to improper neutralization of input during web page generation. The issue affects versions through 2.4.27.
- CVE-2026-42703Medium
The Kali Forms plugin for WordPress contains a Missing Authorization vulnerability that allows exploitation of incorrectly configured access control security levels. The issue affects versions through 2.4.27.
- CVE-2026-39782Medium
The Kali Forms plugin through version 2.4.27 contains a missing authorization vulnerability that allows exploitation of incorrectly configured access control levels. This may permit unauthorized operations.
- CVE-2026-81276Medium
Kali Forms version 2.4.23 and earlier has an Unauthenticated Broken Access Control vulnerability. This means an unauthenticated attacker can access functions that should be protected.
- CVE-2026-16144High
The Kali Forms plugin for WordPress is vulnerable to remote code execution via the `_save_data()` function. Insufficient validation of the `thisPermalink` field allows unauthenticated attackers to pass a controlled string to `call_user_func()`, enabling code execution on the server.
- CVE-2026-65446High
A Cross Site Scripting (XSS) vulnerability in the Kali Forms plugin for WordPress versions up to 2.4.18. An unauthenticated attacker can inject a malicious script.
- CVE-2026-59542High
The Kali Forms plugin version 2.4.18 and earlier allows a user with the Subscriber role to delete arbitrary files on the server. The vulnerability does not require special privileges beyond a standard subscriber account.
- CVE-2026-15395High
The Kali Forms plugin for WordPress (versions up to 2.4.18) is vulnerable to stored XSS via the 'digitalSignature' field. Insufficient input sanitization and output escaping allow unauthenticated attackers to inject arbitrary scripts that execute when users access the affected page.
- CVE-2026-11580Medium
The Kali Forms WordPress plugin before version 2.4.17 lacks a per-object capability check in its post-duplication AJAX action, allowing users with Contributor-level access or above to duplicate any post (regardless of owner, post type, or status) into a published post they own and read its private post metadata, including secrets stored by the plugin.
- CVE-2026-9107Medium
The Kali Forms plugin for WordPress up to version 2.4.13 is vulnerable to Stored XSS via the 'meta[kaliforms_field_components]' parameter. Authenticated attackers with contributor-level access or higher can inject arbitrary scripts that execute when a user visits the compromised page.
Original NVD description (English source)
The Kali Forms — Contact Form & Drag-and-Drop Builder WordPress plugin before 2.4.17 does not verify that a file upload is made against an existing form configured with a file-upload field, accepting uploads regardless of whether any such form exists, which allows unauthenticated users to upload files to the WordPress Media Library; the uploads are limited to WordPress's default-allowed MIME types, so this does not lead to code execution.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

