CVE Catalog

CVE-2026-114570

MediumCVSS 4.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

7th percentile - higher than 7% of all known CVEs

Summary

WordPress Core (all versions up to and including 7.0.2) is vulnerable to stored Cross-Site Scripting via Quick Edit due to insufficient escaping of user display names. An authenticated attacker with Contributor-level access or above can inject arbitrary web scripts that execute when a higher-privileged user accesses the affected administrative screens. This issue only affects sites with a large number of users.

Risk Assessment

An attacker with a Contributor account can inject malicious scripts that execute in an administrator's browser, potentially leading to session hijacking or actions performed on behalf of a privileged user. The risk affects sites with a large number of users.

Recommendation

Update WordPress Core to a version later than 7.0.2. Limit the number of elevated-privilege accounts and review user display names.

Other vulnerabilities in WordPress Core

Original NVD description (English source)

WordPress Core is vulnerable to Stored Cross-Site Scripting via Quick Edit in all versions up to, and including, 7.0.2 due to insufficient escaping of user display names. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a higher privileged user accesses the affected administrative screens. This issue only affects sites with a large number of users.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS